summaryrefslogtreecommitdiffstats
path: root/abs/extra/dotconf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/dotconf/PKGBUILD')
-rw-r--r--abs/extra/dotconf/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/dotconf/PKGBUILD b/abs/extra/dotconf/PKGBUILD
new file mode 100644
index 0000000..07e7e91
--- /dev/null
+++ b/abs/extra/dotconf/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Chris Brannon <cmbrannon@cox.net>
+
+pkgname=dotconf
+pkgver=1.3
+pkgrel=3
+pkgdesc='A C library for parsing configuration files'
+url="https://github.com/williamh/dotconf"
+arch=('i686' 'x86_64')
+depends=('glibc')
+makedepends=('pkgconfig' 'findutils')
+license=('LGPL2.1')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/williamh/${pkgname}/tarball/v${pkgver}")
+md5sums=('36bfdde245072fc2f4f5766b7db97c45')
+options=('!libtool')
+
+build() {
+ cd "${srcdir}"/williamh-${pkgname}-4cd7b3a
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/williamh-${pkgname}-4cd7b3a
+ make DESTDIR="${pkgdir}" install
+}