summaryrefslogtreecommitdiffstats
path: root/abs/extra/gamin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gamin/PKGBUILD')
-rw-r--r--abs/extra/gamin/PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/abs/extra/gamin/PKGBUILD b/abs/extra/gamin/PKGBUILD
new file mode 100644
index 0000000..495eab4
--- /dev/null
+++ b/abs/extra/gamin/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id$
+# Maintainer:
+# Contributor: Abhishek Dasgupta <abhidg@gmail.com>
+# Contributor: Pulphix <crimea.v@libero.it>
+
+pkgname=gamin
+pkgver=0.1.10
+pkgrel=8
+pkgdesc='File and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor)'
+url='http://www.gnome.org/~veillard/gamin'
+license=('GPL')
+arch=('x86_64')
+depends=('glib2')
+makedepends=('python2')
+optdepends=('python2: for the python module')
+provides=('fam')
+conflicts=('fam')
+source=("$url/sources/${pkgname}-${pkgver}.tar.gz"
+ 'fix-deprecated-const.patch'
+ '18_gam_server_deadlocks.patch'
+ '0001-Poll-files-on-nfs4.patch')
+md5sums=('b4ec549e57da470c04edd5ec2876a028'
+ 'f679aeb48fe9dd376c8828cc9b6941ab'
+ '4784359a3206bfa3c0dce1c23468f87f'
+ '6711cd0b1e8d2ad038c5761715d084a5')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # https://bugs.archlinux.org/task/33642
+ patch -Np1 -i ../18_gam_server_deadlocks.patch
+
+ patch -Np1 -i ../fix-deprecated-const.patch
+ patch -Np1 -i ../0001-Poll-files-on-nfs4.patch
+
+ # python 2
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' python/gamin.py
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --disable-static --with-threads \
+ --disable-debug-api --disable-debug --libexecdir=/usr/lib/gamin \
+ --with-python=/usr/bin/python2
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: