summaryrefslogtreecommitdiffstats
path: root/abs/extra/gd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gd/PKGBUILD')
-rw-r--r--abs/extra/gd/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra/gd/PKGBUILD b/abs/extra/gd/PKGBUILD
new file mode 100644
index 0000000..3df77a1
--- /dev/null
+++ b/abs/extra/gd/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+
+pkgname=gd
+pkgver=2.0.35
+pkgrel=2
+pkgdesc="Library for the dynamic creation of images by programmers"
+arch=('i686' 'x86_64')
+url="http://www.libgd.org/"
+license=('custom')
+depends=('libpng>=1.2.16' 'fontconfig>=2.4.2' 'libjpeg')
+options=('!libtool')
+source=(http://www.libgd.org/releases/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('6c6c3dbb7bf079e0bb5fbbfd3bb8a71c')
+sha1sums=('ccf34a610abff2dbf133a20c4d2a4aa94939018a')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --without-xpm
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+ install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+}