summaryrefslogtreecommitdiffstats
path: root/abs/extra/gd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gd/PKGBUILD')
-rw-r--r--abs/extra/gd/PKGBUILD30
1 files changed, 10 insertions, 20 deletions
diff --git a/abs/extra/gd/PKGBUILD b/abs/extra/gd/PKGBUILD
index 4988f09..75242e6 100644
--- a/abs/extra/gd/PKGBUILD
+++ b/abs/extra/gd/PKGBUILD
@@ -1,43 +1,33 @@
# $Id$
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=gd
-pkgver=2.1.1
+pkgver=2.2.3
pkgrel=3
pkgdesc="Library for the dynamic creation of images by programmers"
arch=('i686' 'x86_64')
url="http://www.libgd.org/"
license=('custom')
-depends=('fontconfig' 'libvpx' 'libxpm' 'libtiff')
-makedepends=('git')
+depends=('fontconfig' 'libxpm' 'libwebp')
optdepends=('perl: bdftogd script')
-source=("${pkgname}::git+https://github.com/libgd/libgd.git#tag=${pkgname}-${pkgver}"
- gd-2.1.1-libvpx-1.4.0.patch)
-md5sums=('SKIP'
- '9114dd8259aaa88b0a09188fe7b19afc')
-
-prepare() {
- cd ${pkgname}
- ./bootstrap.sh
- patch -p1 -i "${srcdir}/gd-2.1.1-libvpx-1.4.0.patch"
-}
+source=("https://github.com/libgd/libgd/releases/download/gd-${pkgver}/libgd-${pkgver}.tar.xz")
+md5sums=('14e4134c129b4c166c3a0549a32ef340')
build() {
- cd ${pkgname}
+ cd libgd-${pkgver}
./configure \
--prefix=/usr \
- --disable-rpath \
- --with-vpx=/usr \
- --with-tiff=/usr
+ --disable-rpath
make
}
check() {
- cd ${pkgname}
- make check
+ cd libgd-${pkgver}
+ [[ ${CARCH} == 'i686' ]] || make check
}
package() {
- cd ${pkgname}
+ cd libgd-${pkgver}
make DESTDIR="${pkgdir}" install
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}