summaryrefslogtreecommitdiffstats
path: root/abs/extra/gnome-python-extras/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gnome-python-extras/PKGBUILD')
-rw-r--r--abs/extra/gnome-python-extras/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra/gnome-python-extras/PKGBUILD b/abs/extra/gnome-python-extras/PKGBUILD
new file mode 100644
index 0000000..297ef68
--- /dev/null
+++ b/abs/extra/gnome-python-extras/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 35285 2009-04-11 20:46:50Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gnome-python-extras
+pkgver=2.25.3
+pkgrel=1
+pkgdesc="Gnome Python interfaces for libraries not part of the core platform"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL')
+depends=('gnome-python>=2.22.1')
+makedepends=('libgtkhtml' 'gtkspell' 'gdl' 'xulrunner>=1.9' 'libgksu' 'pkgconfig' 'libgnomeui' 'libgda')
+optdepends=('libgtkhtml' 'gtkspell' 'gdl' 'xulrunner' 'libgksu' 'libgnomeui' 'libgda')
+options=('!libtool')
+source=(http://ftp.gnome.org/pub/gnome/sources/gnome-python-extras/2.25/gnome-python-extras-${pkgver}.tar.bz2)
+url="http://www.daa.com.au/~james/pygtk/"
+md5sums=('9f3b7ec5c57130b96061cb486b79c076')
+
+build() {
+ cd "${srcdir}/gnome-python-extras-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make MOZILLA_HOME=/usr/lib/xulrunner-1.9 || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}