summaryrefslogtreecommitdiffstats
path: root/abs/extra/gnome-python/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gnome-python/PKGBUILD')
-rw-r--r--abs/extra/gnome-python/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra/gnome-python/PKGBUILD b/abs/extra/gnome-python/PKGBUILD
new file mode 100644
index 0000000..d9e0045
--- /dev/null
+++ b/abs/extra/gnome-python/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 16730 2008-10-22 02:56:32Z allan $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+
+pkgname=gnome-python
+pkgver=2.22.3
+pkgrel=3
+pkgdesc="gnome-python is a set of interfaces to gnome-libs."
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('pygtk>=2.13.0' 'pyorbit>=2.24.0' 'libgnomeui>=2.24.0')
+makedepends=('pkgconfig')
+groups=('gnome')
+options=('!libtool')
+url="http://www.pygtk.org/"
+source=(http://ftp.gnome.org/pub/gnome/sources/gnome-python/2.22/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('ab12d94954a57de39b25eb7903d8429c')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./waf configure --prefix=/usr || return 1
+ ./waf build ${MAKEFLAGS} || return 1
+ ./waf install --destdir="${pkgdir}" || return 1
+}