summaryrefslogtreecommitdiffstats
path: root/abs/extra/google-chrome/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/google-chrome/PKGBUILD')
-rw-r--r--abs/extra/google-chrome/PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index 732d627..0c3a393 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,23 +5,26 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=56.0.2924.87
+pkgver=57.0.2987.110
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('x86_64')
url="https://www.google.com/chrome"
license=('custom:chrome')
-depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfbuzz-icu' 'hicolor-icon-theme'
- 'icu' 'libpng' 'libxss' 'libxtst' 'nss' 'opus' 'snappy' 'speech-dispatcher' 'ttf-font' 'xdg-utils')
-optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
- 'ttf-liberation: fix fonts for some PDFs')
-provides=('google-chrome' 'pepper-flash')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss')
+optdepends=('kdialog: needed for file dialogs in KDE'
+ 'gnome-keyring: for storing passwords in GNOME keyring'
+ 'kwallet: for storing passwords in KWallet'
+ 'ttf-liberation: fix fonts for some PDFs (CRBug #369991)')
options=('!emptydirs' '!strip')
install=$pkgname.install
_channel=stable
source=("google-chrome-${_channel}_${pkgver}_amd64.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_amd64.deb"
"$url/browser/privacy/eula_text.html"
'google-chrome-stable.sh')
+md5sums=('ba137093ddd19e643988e66d5821eb3d'
+ 'SKIP'
+ 'ed4cf73982461af7d0d944c1cbf9f4e8')
package() {
msg2 "Extracting the data.tar.xz..."
@@ -30,6 +33,7 @@ package() {
msg2 "Moving stuff in place..."
# Launcher
install -m755 google-chrome-$_channel.sh "$pkgdir"/usr/bin/google-chrome-$_channel
+ mv "$pkgdir"/usr/bin/google-chrome-$_channel "$pkgdir"/usr/bin/google-chrome
# Icons
for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
@@ -49,10 +53,4 @@ package() {
msg2 "Removing Debian Cron job and duplicate product logos..."
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/opt/google/chrome/cron/
rm "$pkgdir"/opt/google/chrome/product_logo_*.png
-
- msg2 "Rename google-chrome-stable to google-chrome..."
- mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome
}
-md5sums=('c0143f6d5b5ffd291def19d2763c41fe'
- 'da54da9383ddffa44c5db45513239da2'
- '99fa93d5e7fb5d622cef0f9621f3ffa3')