summaryrefslogtreecommitdiffstats
path: root/abs/extra/google-chrome/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/google-chrome/PKGBUILD')
-rw-r--r--abs/extra/google-chrome/PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index ca4ae42..c4357a3 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,7 +5,7 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=34.0.1847.116
+pkgver=34.0.1847.132
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('i686' 'x86_64')
@@ -16,16 +16,15 @@ depends=('alsa-lib' 'desktop-file-utils' 'flac' 'gconf' 'gtk2' 'harfbuzz' 'harfb
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
'ttf-google-fonts-git')
provides=("google-chrome=${pkgver}")
-conflicts=('google-chrome<35')
replaces=('chromium')
options=('!emptydirs' '!strip')
install=${pkgname}.install
_channel=stable
_arch=i386
[ "${CARCH}" = 'x86_64' ] && _arch=amd64
-source=("google-chrome-${_channel}_${pkgver}_${_arch}.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_${_arch}.deb"
- 'https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html')
-[ "${CARCH}" = 'x86_64' ] && md5sums[0]='f0186cc5b1f6ceb0166abb0628182663'
+source=("google-chrome-${_channel}_${pkgver}_${_arch}.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_${_arch}.deb")
+md5sums=('7a25fe96c07da3f0da72783788aad054')
+[ "${CARCH}" = 'x86_64' ] && md5sums[0]='54515de584acbe880a0adcc828e3173a'
package() {
msg2 "Extracting the data.tar.lzma"
@@ -42,7 +41,9 @@ package() {
gzip "${pkgdir}"/usr/share/man/man1/google-chrome.1
# License
- install -Dm644 eula_text.html "${pkgdir}"/usr/share/licenses/google-chrome/eula_text.html
+ install -d "${pkgdir}"/usr/share/licenses/google-chrome/
+ curl -Ls https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html \
+ -o "${pkgdir}"/usr/share/licenses/google-chrome/eula_text.html
msg2 "Symlinking missing Udev lib"
ln -s /usr/lib/libudev.so.1 "${pkgdir}"/opt/google/chrome/libudev.so.0
@@ -53,7 +54,4 @@ package() {
msg2 "Rename google-chrome-stable to google-chrome"
mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome
-
}
-md5sums=('f0186cc5b1f6ceb0166abb0628182663'
- '6d57da7476a4b1b7a81821d9c036425c')