summaryrefslogtreecommitdiffstats
path: root/abs/extra/google-chrome
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/google-chrome')
-rw-r--r--abs/extra/google-chrome/PKGBUILD15
-rw-r--r--abs/extra/google-chrome/__changelog1
2 files changed, 10 insertions, 6 deletions
diff --git a/abs/extra/google-chrome/PKGBUILD b/abs/extra/google-chrome/PKGBUILD
index 085418c..9127569 100644
--- a/abs/extra/google-chrome/PKGBUILD
+++ b/abs/extra/google-chrome/PKGBUILD
@@ -5,13 +5,13 @@
# or use: $ curl -s https://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/other.xml.gz | gzip -df | awk -F\" '/pkgid/{ sub(".*-","",$4); print $4": "$10 }'
pkgname=google-chrome
-pkgver=30.0.1599.101
+pkgver=31.0.1650.63
pkgrel=1
pkgdesc="An attempt at creating a safer, faster, and more stable browser (Stable Channel)"
arch=('i686' 'x86_64')
url="https://www.google.com/chrome"
license=('custom:chrome')
-depends=('alsa-lib' 'gconf' 'gtk2' 'hicolor-icon-theme' 'libpng' 'libxslt' 'libxss' 'nss' 'ttf-font' 'xdg-utils')
+depends=('alsa-lib' 'gconf' 'gtk2' 'hicolor-icon-theme' 'libpng' 'libxslt' 'libxss' 'libxtst' 'nss' 'ttf-font' 'xdg-utils')
optdepends=('kdebase-kdialog: needed for file dialogs in KDE'
'ttf-google-fonts-git')
provides=("google-chrome=$pkgver")
@@ -23,10 +23,8 @@ _channel=stable
_arch=i386
[ "$CARCH" = 'x86_64' ] && _arch=amd64
source=("google-chrome-${_channel}_${pkgver}_${_arch}.deb::https://dl.google.com/linux/direct/google-chrome-${_channel}_current_${_arch}.deb"
- "$url/intl/en/eula_text.html")
-md5sums=('fa5d706a9f7ef0682de6b665c20f302f'
- '6d57da7476a4b1b7a81821d9c036425c')
-[ "$CARCH" = 'x86_64' ] && md5sums[0]='9abdef7ee0422f7dabb16941453551cc'
+ 'https://www.google.com/intl/en/chrome/browser/privacy/eula_text.html')
+[ "$CARCH" = 'x86_64' ] && md5sums[0]='83c6ddb1c281da8243aba0b5f2e3763f'
#PKGEXT='.pkg.tar'
@@ -55,4 +53,9 @@ package() {
msg2 "Removing the Debian-intended cron job and duplicated images"
rm -r "$pkgdir"/etc/cron.daily/ "$pkgdir"/opt/google/chrome/cron/
rm "$pkgdir"/opt/google/chrome/product_logo_*.png
+
+ msg2 "Rename google-chrome-stable to google-chrome"
+ mv "$pkgdir"/usr/bin/google-chrome-stable "$pkgdir"/usr/bin/google-chrome
}
+md5sums=('83c6ddb1c281da8243aba0b5f2e3763f'
+ '6d57da7476a4b1b7a81821d9c036425c')
diff --git a/abs/extra/google-chrome/__changelog b/abs/extra/google-chrome/__changelog
index 20fbc77..c280aef 100644
--- a/abs/extra/google-chrome/__changelog
+++ b/abs/extra/google-chrome/__changelog
@@ -3,3 +3,4 @@ Pull from ARU: https://aur.archlinux.org/packages/google-chrome/
- PKGBUILD: comment out PKGEXT so we compress the pkg
- PKGBUILD: add replaces chromium
- google-chrome.install: add symlink from /usr/bin/chromium to google-chrome so as not to break pkgs that use chromium
+- Rename google-chrome-stable to google-chrome"