summaryrefslogtreecommitdiffstats
path: root/abs/extra/graphviz/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/graphviz/PKGBUILD')
-rw-r--r--abs/extra/graphviz/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/abs/extra/graphviz/PKGBUILD b/abs/extra/graphviz/PKGBUILD
index 0ee8e34..2eb0135 100644
--- a/abs/extra/graphviz/PKGBUILD
+++ b/abs/extra/graphviz/PKGBUILD
@@ -4,39 +4,40 @@
# Contributor: John Proctor <jproctor@prium.net>
pkgname=graphviz
-pkgver=2.38.0
-pkgrel=3
+pkgver=2.40.1
+pkgrel=1
pkgdesc='Graph visualization software'
url='http://www.graphviz.org/'
license=('CPL')
arch=('i686' 'x86_64')
depends=('libltdl' 'gd' 'librsvg' 'libxaw' 'ghostscript' 'pango' 'gts')
-makedepends=('swig' 'mono' 'guile' 'lua51' 'ocaml' 'perl' 'php' 'python2' 'r' 'tk' 'qt4' 'gtk2')
+makedepends=('swig' 'mono' 'guile' 'lua51' 'ocaml' 'perl' 'python2' 'r' 'tk' 'qt4' 'gtk2')
optdepends=('mono: sharp bindings'
'guile: guile bindings'
'lua51: lua bindings'
'ocaml: ocaml bindings'
'perl: perl bindings'
- 'php: php bindings'
'python2: python bindings'
'r: r bindings'
'tcl: tcl bindings'
'qt4: gvedit'
- 'gtk2: gtk output plugin')
+ 'gtk2: gtk output plugin'
+ 'xterm: vimdot')
source=("${url}/pub/${pkgname}/stable/SOURCES/${pkgname}-${pkgver}.tar.gz"
- 'format-string.patch')
-sha1sums=('053c771278909160916ca5464a0a98ebf034c6ef'
- '271d116bc022596a64b6ee061f3d2e50fa2e6025')
+ 'ghostscript918.patch')
+sha1sums=('8a44d19bcdb50df1bd8e649de472ebf868468888'
+ 'bcce75a535c277556e196638e59ea019b0a63fa1')
install=install
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i ../format-string.patch # FS#42983
+ patch -p1 -i ../ghostscript918.patch
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ export CXXFLAGS+=' -Dint64=int64_t' # for ocaml
export LIBPOSTFIX=/
export PYTHON=python2
export LUA=lua5.1
@@ -49,9 +50,13 @@ package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+ cd "${pkgdir}/usr/lib"
+ install -d lua/5.1
+ mv lua/gv.so lua/5.1
+
# Workaround symlink upgrade bug (fixed in pacman trunk)
# Also deduplicates the tcl libraries (upstream bug?)
# Might have been this commit: https://github.com/ellson/graphviz/commit/f11aead
- rm -r "${pkgdir}/usr/lib/tcl8.6/graphviz"
- ln -s ../graphviz/tcl "$pkgdir/usr/lib/tcl8.6/graphviz"
+ rm -r tcl8.6/graphviz
+ ln -s ../graphviz/tcl tcl8.6/graphviz
}