summaryrefslogtreecommitdiffstats
path: root/abs/extra/gsettings-desktop-schemas/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/gsettings-desktop-schemas/PKGBUILD')
-rw-r--r--abs/extra/gsettings-desktop-schemas/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/extra/gsettings-desktop-schemas/PKGBUILD b/abs/extra/gsettings-desktop-schemas/PKGBUILD
new file mode 100644
index 0000000..4474c2a
--- /dev/null
+++ b/abs/extra/gsettings-desktop-schemas/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 159084 2012-05-15 13:43:27Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Adam Hani Schakaki (krzd) <krzd@krzd.net>
+
+pkgname=gsettings-desktop-schemas
+pkgver=3.4.2
+pkgrel=1
+pkgdesc="Shared GSettings schemas for the desktop"
+arch=('any')
+url="http://live.gnome.org/"
+license=('GPL')
+depends=('glib2')
+makedepends=('intltool' 'gobject-introspection')
+install=$pkgname.install
+source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('ce0a460128d52710b6842ca663690e38374ac921e2f6c1bdf5d54f46aa6eba4f')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-schemas-compile
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}