summaryrefslogtreecommitdiffstats
path: root/abs/extra/help2man/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/help2man/PKGBUILD')
-rw-r--r--abs/extra/help2man/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/help2man/PKGBUILD b/abs/extra/help2man/PKGBUILD
new file mode 100644
index 0000000..ef9642e
--- /dev/null
+++ b/abs/extra/help2man/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 67994 2010-02-10 11:34:11Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Paul Mattal <paul@mattal.com>
+
+pkgname=help2man
+pkgver=1.37.1
+pkgrel=1
+pkgdesc="Conversion tool to create man files"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/help2man/"
+license=('GPL')
+depends=('perl-locale-gettext')
+source=(http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ help2man-1.37.1-respect-LDFLAGS.patch)
+md5sums=('371b5cc74fe9c2ea3ee1ca23c19b19a8'
+ '6f80dfd75b46c6bfbc2eeb5516771096')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -Np1 -i ${srcdir}/help2man-1.37.1-respect-LDFLAGS.patch || return 1
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libdir=/lib
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}