summaryrefslogtreecommitdiffstats
path: root/abs/extra/help2man/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/help2man/PKGBUILD')
-rw-r--r--abs/extra/help2man/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/abs/extra/help2man/PKGBUILD b/abs/extra/help2man/PKGBUILD
index c9dc9fb..fff2829 100644
--- a/abs/extra/help2man/PKGBUILD
+++ b/abs/extra/help2man/PKGBUILD
@@ -1,17 +1,18 @@
-# $Id: PKGBUILD 83522 2010-06-21 22:45:22Z giovanni $
+# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Paul Mattal <paul@mattal.com>
pkgname=help2man
-pkgver=1.38.2
+pkgver=1.40.4
pkgrel=1
pkgdesc="Conversion tool to create man files"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/help2man/"
license=('GPL')
depends=('perl-locale-gettext')
-source=(http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('426671c6fe79e5ef2233303367eab5a6')
+install=help2man.install
+source=("http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('4d79dc7cb7c20019c2a3650d35259c45')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -20,6 +21,11 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--libdir=/lib
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
}