summaryrefslogtreecommitdiffstats
path: root/abs/extra/help2man
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/help2man')
-rw-r--r--abs/extra/help2man/PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/abs/extra/help2man/PKGBUILD b/abs/extra/help2man/PKGBUILD
index ef9642e..f03c47c 100644
--- a/abs/extra/help2man/PKGBUILD
+++ b/abs/extra/help2man/PKGBUILD
@@ -1,28 +1,30 @@
-# $Id: PKGBUILD 67994 2010-02-10 11:34:11Z giovanni $
+# $Id$
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Paul Mattal <paul@mattal.com>
pkgname=help2man
-pkgver=1.37.1
+pkgver=1.38.4
pkgrel=1
pkgdesc="Conversion tool to create man files"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/help2man/"
license=('GPL')
depends=('perl-locale-gettext')
-source=(http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz
- help2man-1.37.1-respect-LDFLAGS.patch)
-md5sums=('371b5cc74fe9c2ea3ee1ca23c19b19a8'
- '6f80dfd75b46c6bfbc2eeb5516771096')
+source=(http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('1441847905ca8e6b7d63def44c3be01e')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i ${srcdir}/help2man-1.37.1-respect-LDFLAGS.patch || return 1
./configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--libdir=/lib
make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install || return 1
}
+