summaryrefslogtreecommitdiffstats
path: root/abs/extra/hspell/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/hspell/PKGBUILD')
-rw-r--r--abs/extra/hspell/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra/hspell/PKGBUILD b/abs/extra/hspell/PKGBUILD
new file mode 100644
index 0000000..7700435
--- /dev/null
+++ b/abs/extra/hspell/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 28768 2009-03-02 04:21:08Z eric $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=hspell
+pkgver=1.0
+pkgrel=2
+pkgdesc="Hebrew spell-checker"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.ivrix.org.il/projects/spell-checker/"
+depends=('glibc>=2.7' 'zlib' 'perl')
+options=('!libtool' '!makeflags')
+source=(ftp://ftp.archlinux.org/other/hspell/${pkgname}-${pkgver}.tar.gz)
+md5sums=('3e12fa383c2cfd430918d115f33f9841')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ [ "${CARCH}" = "x86_64" ] && export CFLAGS="${CFLAGS} -fPIC"
+ sed -i -e 's|/usr/bin/awk|/bin/awk|' wzip
+ ./configure --prefix=/usr --enable-linginfo
+ make || return 1
+ make DESTDIR=${startdir}/pkg/ install || return 1
+}