summaryrefslogtreecommitdiffstats
path: root/abs/extra/htop/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/htop/PKGBUILD')
-rw-r--r--abs/extra/htop/PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/abs/extra/htop/PKGBUILD b/abs/extra/htop/PKGBUILD
index 326a98a..95b9660 100644
--- a/abs/extra/htop/PKGBUILD
+++ b/abs/extra/htop/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Alexander Fehr <pizzapunk gmail com>
pkgname=htop
-pkgver=0.8.1
+pkgver=0.8.3
pkgrel=1
pkgdesc="Interactive process viewer"
arch=('i686' 'x86_64')
@@ -10,19 +10,13 @@ url="http://htop.sourceforge.net/"
license=('GPL')
depends=('ncurses')
options=('!emptydirs')
-source=(http://downloads.sourceforge.net/htop/htop-$pkgver.tar.gz
- htop-treeview.patch)
-md5sums=('f0b259ca29175656de48bf0fa0a2e619'
- '54613e5237592691da8903fae05780d9')
+source=(http://downloads.sourceforge.net/htop/htop-$pkgver.tar.gz)
build() {
cd "$srcdir/htop-$pkgver"
-
- # Fix tree view
- # http://sourceforge.net/tracker2/?func=detail&aid=2343835&group_id=108839&atid=651635
- patch -Np1 -i "$srcdir/htop-treeview.patch" || return 1
-
+ sed -i 's|ncursesw/curses.h|curses.h|' RichString.h RichString.c || return 1
./configure --prefix=/usr --enable-unicode || return 1
make || return 1
make DESTDIR="$pkgdir" install || return 1
}
+md5sums=('5c9f093f9eaddf6e77aa6d54c2116d0c')