summaryrefslogtreecommitdiffstats
path: root/abs/extra/htop/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/htop/PKGBUILD')
-rw-r--r--abs/extra/htop/PKGBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/abs/extra/htop/PKGBUILD b/abs/extra/htop/PKGBUILD
index 531cf81..09664d5 100644
--- a/abs/extra/htop/PKGBUILD
+++ b/abs/extra/htop/PKGBUILD
@@ -1,22 +1,33 @@
# $Id$
-# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=htop
-pkgver=2.0.1
-pkgrel=1
+pkgver=2.2.0
+pkgrel=2
pkgdesc="Interactive process viewer"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://hisham.hm/htop/"
license=('GPL')
-depends=('ncurses')
-makedepends=('python2')
+depends=('ncurses' 'libnl')
+makedepends=('python')
optdepends=('lsof: show files opened by a process'
'strace: attach to a running process')
-options=('!emptydirs')
-source=("http://hisham.hm/$pkgname/releases/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('f75fe92b4defaa80d99109830f34b5e2')
+options=('!emptydirs' debug)
+validpgpkeys=('8460980B2B79786DE0C7FCC83FD8F43C2BB3C478') # Hisham Muhammad <h@hisham.hm>
+source=("https://hisham.hm/$pkgname/releases/$pkgver/$pkgname-$pkgver.tar.gz"{,.asc}
+ '0001-fix-option-string.patch')
+sha256sums=('d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57'
+ 'SKIP'
+ 'e0ea3a91dfbc7f8c516a19e0d8890314845e768ea4132dfaa49c4d4e89ec10ca')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -Np1 < "${srcdir}"/0001-fix-option-string.patch
+}
build() {
cd "$pkgname-$pkgver"
@@ -24,10 +35,11 @@ build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --enable-unicode \
+ --enable-cgroup \
+ --enable-delayacct \
--enable-openvz \
- --enable-vserver \
- --enable-cgroup
+ --enable-unicode \
+ --enable-vserver
make
}