summaryrefslogtreecommitdiffstats
path: root/abs/extra/icu/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/icu/PKGBUILD')
-rw-r--r--abs/extra/icu/PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/abs/extra/icu/PKGBUILD b/abs/extra/icu/PKGBUILD
index 14cd4aa..95b0fab 100644
--- a/abs/extra/icu/PKGBUILD
+++ b/abs/extra/icu/PKGBUILD
@@ -1,24 +1,28 @@
-# $Id: PKGBUILD 92974 2010-10-02 16:39:18Z andyrtr $
+# $Id: PKGBUILD 160960 2012-06-07 13:35:03Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Art Gramlich <art@gramlich-net.com>
pkgname=icu
-pkgver=4.4.2
+pkgver=49.1.2
pkgrel=1
pkgdesc="International Components for Unicode library"
arch=(i686 x86_64)
url="http://www.icu-project.org/"
license=('custom:"icu"')
depends=('gcc-libs' 'sh')
-source=(http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz
- #http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver/./_}-src.tgz
-)
-md5sums=('314e582264c36b3735466c522899aa07')
-
+source=(#http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver/./_}-src.tgz
+ http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz
+ icu.8198.revert.icu5431.patch)
+md5sums=('bbc609fe5237202d7abf016141012a45'
+ 'ebd5470fc969c75e52baf4af94a9ee82')
build() {
cd ${srcdir}/icu/source
- ./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
+ # fix Malayalam encoding https://bugzilla.redhat.com/show_bug.cgi?id=654200
+ patch -Rp3 -i ${srcdir}/icu.8198.revert.icu5431.patch
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
make
}