summaryrefslogtreecommitdiffstats
path: root/abs/extra/ifenslave/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/ifenslave/PKGBUILD')
-rw-r--r--abs/extra/ifenslave/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/abs/extra/ifenslave/PKGBUILD b/abs/extra/ifenslave/PKGBUILD
new file mode 100644
index 0000000..8a75170
--- /dev/null
+++ b/abs/extra/ifenslave/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 12836 2008-09-21 14:41:26Z dan $
+# Maintainer: Judd Vinet <jvinet@zeroflux.org>
+pkgname=ifenslave
+pkgver=1.1.0
+pkgrel=4
+pkgdesc="Utility for bonding ethernet interfaces"
+license=('GPL2')
+arch=(i686 x86_64)
+url="http://www.linuxfoundation.org/en/Net:Bonding"
+depends=('glibc')
+source=(ftp://ftp.archlinux.org/other/ifenslave/ifenslave.c bonding.conf.d)
+md5sums=('b0d8e4c97094155747cc9238f762c7aa'
+ '397fccbf574d5082c7a3c8d3793dc000')
+
+build() {
+ cd $startdir/src
+ gcc $CFLAGS -I/usr/src/linux/include ifenslave.c -o ifenslave || return 1
+ install -D -m755 ifenslave $startdir/pkg/sbin/ifenslave
+ install -D -m644 bonding.conf.d $startdir/pkg/etc/conf.d/bonding
+}