summaryrefslogtreecommitdiffstats
path: root/abs/extra/libbonobo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libbonobo/PKGBUILD')
-rw-r--r--abs/extra/libbonobo/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra/libbonobo/PKGBUILD b/abs/extra/libbonobo/PKGBUILD
new file mode 100644
index 0000000..93e2538
--- /dev/null
+++ b/abs/extra/libbonobo/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 29425 2009-03-08 17:32:56Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libbonobo
+pkgver=2.24.1
+pkgrel=1
+pkgdesc="A set of language and system independant CORBA interfaces for creating reusable components"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL')
+depends=('orbit2>=2.14.17' 'libxml2>=2.7.3' 'dbus-glib>=0.78')
+makedepends=('intltool' 'pkgconfig' 'flex')
+options=('!libtool')
+backup=('etc/bonobo-activation/bonobo-activation-config.xml')
+replaces=('bonobo-activation')
+url="http://www.gnome.org"
+source=(http://ftp.gnome.org/pub/gnome/sources/libbonobo/2.24/libbonobo-${pkgver}.tar.bz2
+ bonobo-activation-config.xml)
+install=libbonobo.install
+md5sums=('8868b6083392964a6969547ceb8d7cd1'
+ '6392efaca30a26f826eafc4b8ccbc01f')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --libexecdir=/usr/lib/bonobo || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -m644 "${srcdir}/bonobo-activation-config.xml" "${pkgdir}/etc/bonobo-activation/" || return 1
+}