summaryrefslogtreecommitdiffstats
path: root/abs/extra/libcap-ng/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libcap-ng/PKGBUILD')
-rw-r--r--abs/extra/libcap-ng/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra/libcap-ng/PKGBUILD b/abs/extra/libcap-ng/PKGBUILD
new file mode 100644
index 0000000..1e3544b
--- /dev/null
+++ b/abs/extra/libcap-ng/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 139367 2011-10-01 18:59:37Z ibiru $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+pkgname=libcap-ng
+pkgver=0.6.6
+pkgrel=1
+pkgdesc="A library intended to make programming with POSIX capabilities much easier than the traditional libcap"
+arch=('i686' 'x86_64')
+url="http://people.redhat.com/sgrubb/libcap-ng/"
+license=('GPL2' 'LGPL2.1')
+depends=('glibc')
+options=('!libtool')
+source=(http://people.redhat.com/sgrubb/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('eb71f967cecb44b4342baac98ef8cb0f')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr --enable-static=no --with-python=no
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+}
+
+# vim:set ts=2 sw=2 et: