summaryrefslogtreecommitdiffstats
path: root/abs/extra/libdvdnav
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libdvdnav')
-rw-r--r--abs/extra/libdvdnav/PKGBUILD30
-rw-r--r--abs/extra/libdvdnav/deadlock.patch17
2 files changed, 0 insertions, 47 deletions
diff --git a/abs/extra/libdvdnav/PKGBUILD b/abs/extra/libdvdnav/PKGBUILD
deleted file mode 100644
index 67c56e4..0000000
--- a/abs/extra/libdvdnav/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# $Id: PKGBUILD 69820 2010-02-22 22:23:44Z giovanni $
-# Maintainer: arjan <arjan@archlinux.org>
-# contributor Sarah Hay <sarahhay@mb.sympatico.ca>
-
-pkgname=libdvdnav
-pkgver=4.1.3
-pkgrel=2
-pkgdesc="The library for xine-dvdnav plugin."
-arch=(i686 x86_64)
-license=('GPL')
-url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
-depends=('libdvdread>=4.1.3')
-options=(!libtool)
-source=(http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2
- deadlock.patch)
-md5sums=('d62383c45b28816771e283515f2c27fa'
- '864529165a1136ae4c1ccbc7b43cdb1a')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch -Np1 -i ${srcdir}/deadlock.patch || return 1
-
- ./autogen.sh --prefix=/usr || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
-}
-
-md5sums=('d62383c45b28816771e283515f2c27fa'
- 'd26d9ab9d705e4e3fa16e0592ad33c79')
diff --git a/abs/extra/libdvdnav/deadlock.patch b/abs/extra/libdvdnav/deadlock.patch
deleted file mode 100644
index 2a58240..0000000
--- a/abs/extra/libdvdnav/deadlock.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/dvdnav.c 2009-11-08 16:58:25.000000000 +0300
-+++ b/src/dvdnav.c 2009-11-08 16:58:52.000000000 +0300
-@@ -180,12 +180,13 @@
- pthread_mutex_unlock(&this->vm_lock);
- return DVDNAV_STATUS_ERR;
- }
-+ pthread_mutex_unlock(&this->vm_lock);
-+
- #ifdef LOG_DEBUG
- fprintf(MSG_OUT, "libdvdnav: clearing dvdnav\n");
- #endif
- result = dvdnav_clear(this);
-
-- pthread_mutex_unlock(&this->vm_lock);
- return result;
- }
-