summaryrefslogtreecommitdiffstats
path: root/abs/extra/libdvdread/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libdvdread/PKGBUILD')
-rw-r--r--abs/extra/libdvdread/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/libdvdread/PKGBUILD b/abs/extra/libdvdread/PKGBUILD
new file mode 100644
index 0000000..edbdaa4
--- /dev/null
+++ b/abs/extra/libdvdread/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 80196 2010-05-13 15:59:09Z andrea $
+# Maintainer:
+# Contributor: Thomas Baechler <thomas@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=libdvdread
+pkgver=4.1.3
+pkgrel=2
+pkgdesc="Provides a simple foundation for reading DVD video disks"
+arch=(i686 x86_64)
+url="http://www.mplayerhq.hu/MPlayer/releases/dvdnav/"
+license=('GPL')
+depends=('glibc')
+makedepends=('libdvdcss')
+optdepends=('libdvdcss: for decoding encrypted DVDs')
+options=('!libtool')
+source=("http://www.mplayerhq.hu/MPlayer/releases/dvdnav/${pkgname}-${pkgver}.tar.bz2"
+ 'DVDFileStat.patch')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # http://lists.mplayerhq.hu/pipermail/dvdnav-discuss/2009-February/000986.html (FS#19324)
+ patch -Np1 -i ${srcdir}/DVDFileStat.patch || return 1
+
+ ./autogen.sh --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums=('6dc068d442c85a3cdd5ad3da75f6c6e8'
+ '140d02afbf66bfbf034549157ed4f7ad')