summaryrefslogtreecommitdiffstats
path: root/abs/extra/libglvnd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libglvnd/PKGBUILD')
-rw-r--r--abs/extra/libglvnd/PKGBUILD33
1 files changed, 0 insertions, 33 deletions
diff --git a/abs/extra/libglvnd/PKGBUILD b/abs/extra/libglvnd/PKGBUILD
deleted file mode 100644
index e589b42..0000000
--- a/abs/extra/libglvnd/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# $Id: PKGBUILD 249779 2015-10-27 00:47:25Z eric $
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-
-pkgname=libglvnd
-pkgver=1.0.0
-pkgrel=1
-pkgdesc="The GL Vendor-Neutral Dispatch library"
-arch=('x86_64')
-url="https://github.com/NVIDIA/libglvnd"
-license=('custom:BSD-like')
-makedepends=('libxext' 'libx11' 'glproto' 'python2')
-provides=('libgl' 'libegl' 'libgles')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v$pkgver.tar.gz"
- LICENSE)
-sha512sums=('c6040b0a508a6b74d7113f8e375fcaf93ec6f2875504953f30e2882e58e22f954bd4027a7d9ab8ac41abef266039e5834fdaf4ce2a69d5d98acf3bbdd54f04b6'
- 'bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5')
-
-build() {
- cd $pkgname-$pkgver
- ./autogen.sh
- ./configure --prefix=/usr
- make
-}
-
-package() {
- # libglvnd needs mesa for indirect rendering
- depends=('libxext' 'mesa' 'opengl-driver')
-
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
-
- install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}