summaryrefslogtreecommitdiffstats
path: root/abs/extra/libimobiledevice/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libimobiledevice/PKGBUILD')
-rw-r--r--abs/extra/libimobiledevice/PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/abs/extra/libimobiledevice/PKGBUILD b/abs/extra/libimobiledevice/PKGBUILD
index 81a8003..bc921ac 100644
--- a/abs/extra/libimobiledevice/PKGBUILD
+++ b/abs/extra/libimobiledevice/PKGBUILD
@@ -1,27 +1,23 @@
-# $Id$
+# $Id: PKGBUILD 164989 2012-08-08 00:24:19Z tomegun $
# Maintainer : Ionut Biru <ibiru@archlinux.org>
# Contributor: Gabriel Martinez < reitaka at gmail dot com >
pkgname=libimobiledevice
-pkgver=1.1.1
-pkgrel=3
+pkgver=1.1.4
+pkgrel=2
pkgdesc="Is a software library that talks the protocols to support iPhone and iPod Touch devices on Linux"
url="http://libimobiledevice.org/"
arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
-depends=('usbmuxd' 'libplist' 'gnutls' 'libgcrypt')
-makedepends=('python2' 'swig')
+depends=('usbmuxd' 'gnutls' 'libgcrypt')
options=('!libtool')
source=(http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2
- swig-version-check.patch)
-md5sums=('cdc13037e822d9ac2e109536701d153a'
- '8bb215e36fe0e08a72332c108c7842cc')
+ HOME-segfault.patch)
build() {
cd "$pkgname-$pkgver"
- # SWIG version check is wrong (still not fixed upstream)
- patch -p1 -i ../swig-version-check.patch
+ patch -p0 < "$srcdir/HOME-segfault.patch"
PYTHON=/usr/bin/python2 ./configure --prefix=/usr
make
@@ -31,3 +27,5 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
+md5sums=('3f28cbc6a2e30d34685049c0abde5183'
+ '0de709dbf8e79d0b00cca06f5e61d57c')