summaryrefslogtreecommitdiffstats
path: root/abs/extra/libmicrohttpd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libmicrohttpd/PKGBUILD')
-rw-r--r--abs/extra/libmicrohttpd/PKGBUILD38
1 files changed, 24 insertions, 14 deletions
diff --git a/abs/extra/libmicrohttpd/PKGBUILD b/abs/extra/libmicrohttpd/PKGBUILD
index 316d989..ebd9706 100644
--- a/abs/extra/libmicrohttpd/PKGBUILD
+++ b/abs/extra/libmicrohttpd/PKGBUILD
@@ -6,30 +6,40 @@
# Contributor: Mathias Rohnstock <linksoft@gmx.de>
pkgname=libmicrohttpd
-pkgver=0.9.44
+pkgver=0.9.59
pkgrel=1
pkgdesc="a small C library that is supposed to make it easy to run an HTTP server as part of another application."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.gnu.org/software/libmicrohttpd/"
license=('LGPL')
-depends=('gnutls' 'libgcrypt')
-optdepends=('file' 'curl')
-install=libmicrohttpd.install
-source=(ftp://ftp.gnu.org/gnu/libmicrohttpd/$pkgname-$pkgver.tar.gz)
-md5sums=('9101b5ebf8f71792938ae672da314da2')
+depends=('gnutls')
+checkdepends=('curl')
+validpgpkeys=('289FE99E138CF6D473A3F0CFBF7AC4A5EAC2BAF4' # Evgeny Grin (Karlson2k) <k2k@yandex.ru>
+ 'D8423BCB326C7907033929C7939E6BE1E29FC3CC') # Christian Grothoff <christian.grothoff@bfh.ch>
+source=("https://ftp.gnu.org/gnu/libmicrohttpd/$pkgname-$pkgver.tar.gz"{,.sig})
+sha256sums=('9b9ccd7d0b11b0e179f1f58dc2caa3e0c62c8609e1e1dc7dcaadf941b67d923c'
+ 'SKIP')
build() {
cd ${pkgname}-${pkgver}
- ./configure --prefix=/usr --disable-dependency-tracking --enable-largefile \
- --enable-curl --enable-messages --with-pic
+ ./configure \
+ --prefix=/usr \
+ --disable-dependency-tracking \
+ --disable-examples \
+ --enable-curl \
+ --enable-https \
+ --enable-largefile \
+ --enable-messages \
+ --with-pic
make
}
+check() {
+ cd ${pkgname}-${pkgver}
+ make check
+}
+
package() {
cd ${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
- install -Dm644 ${srcdir}/${pkgname}-${pkgver}/src/include/platform.h \
- ${pkgdir}/usr/include/$pkgname/platform.h
- sed -i 's#Cflags: -I${includedir}#Cflags: -I${includedir} -I${includedir}/libmicrohttpd#' \
- $pkgdir/usr/lib/pkgconfig/libmicrohttpd.pc
+ make DESTDIR="$pkgdir" install
}