summaryrefslogtreecommitdiffstats
path: root/abs/extra/libnl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libnl/PKGBUILD')
-rw-r--r--abs/extra/libnl/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/extra/libnl/PKGBUILD b/abs/extra/libnl/PKGBUILD
new file mode 100644
index 0000000..4a6465a
--- /dev/null
+++ b/abs/extra/libnl/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id: PKGBUILD 930 2008-04-24 22:14:40Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+pkgname=libnl
+pkgver=1.1
+pkgrel=2
+pkgdesc="Library for applications dealing with netlink sockets"
+arch=('i686' 'x86_64')
+url="http://people.suug.ch/~tgr/libnl"
+license=('GPL')
+depends=('glibc')
+source=(http://people.suug.ch/~tgr/${pkgname}/files/${pkgname}-${pkgver}.tar.gz ulong_max.patch)
+md5sums=('ae970ccd9144e132b68664f98e7ceeb1' '255bb3740149d518766032675810c590')
+
+build() {
+ cd ${startdir}/src/libnl-${pkgver}
+ patch -p1 < ../ulong_max.patch
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+}