summaryrefslogtreecommitdiffstats
path: root/abs/extra/libraw/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libraw/PKGBUILD')
-rw-r--r--abs/extra/libraw/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/extra/libraw/PKGBUILD b/abs/extra/libraw/PKGBUILD
new file mode 100644
index 0000000..1ab58fc
--- /dev/null
+++ b/abs/extra/libraw/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Joeny Ang <ang(dot)joeny(at)gmail(dot)com>
+# Contributor: Brad Fanella <bradfanella@archlinux.us>
+
+pkgname=libraw
+pkgver=0.18.7
+pkgrel=1
+pkgdesc="A library for reading RAW files obtained from digital photo cameras (CRW/CR2, NEF, RAF, DNG, and others)"
+arch=('x86_64')
+url="https://www.libraw.org/"
+license=(CDDL LGPL)
+depends=(lcms2 jasper)
+source=("https://www.libraw.org/data/LibRaw-${pkgver}.tar.gz")
+sha256sums=('87e347c261a8e87935d9a23afd750d27676b99f540e8552314d40db0ea315771')
+
+build() {
+ cd LibRaw-$pkgver
+ ./configure --prefix=/usr \
+ --disable-examples
+ make
+}
+
+package() {
+ cd LibRaw-$pkgver
+ make DESTDIR="$pkgdir" install
+}