summaryrefslogtreecommitdiffstats
path: root/abs/extra/libsigsegv/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libsigsegv/PKGBUILD')
-rw-r--r--abs/extra/libsigsegv/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/extra/libsigsegv/PKGBUILD b/abs/extra/libsigsegv/PKGBUILD
new file mode 100644
index 0000000..da9e610
--- /dev/null
+++ b/abs/extra/libsigsegv/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id$
+# Maintainer: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Johannes Weiner <hannes@saeurebad.de>
+
+pkgname=libsigsegv
+pkgver=2.12
+pkgrel=1
+arch=('x86_64')
+pkgdesc="Page fault detection library"
+url="http://www.gnu.org/software/libsigsegv/"
+license=('GPL2')
+depends=('glibc')
+source=("http://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('df167811328b050d2b746bec3d88423edc5a8cbf')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --enable-shared
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}