summaryrefslogtreecommitdiffstats
path: root/abs/extra/libxfcegui4/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libxfcegui4/PKGBUILD')
-rw-r--r--abs/extra/libxfcegui4/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/libxfcegui4/PKGBUILD b/abs/extra/libxfcegui4/PKGBUILD
new file mode 100644
index 0000000..c947d2f
--- /dev/null
+++ b/abs/extra/libxfcegui4/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 80816 2010-05-22 13:17:01Z andyrtr $
+# Maintainer: tobias <tobias funnychar archlinux.org>
+
+pkgname=libxfcegui4
+pkgver=4.6.4
+pkgrel=1
+pkgdesc="Various gtk widgets for Xfce"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://www.xfce.org/"
+depends=('startup-notification' "xfconf>=4.6.2" "libglade>=2.6.4" 'hicolor-icon-theme')
+makedepends=('pkgconfig' 'intltool')
+options=('!libtool')
+install=${pkgname}.install
+source=(http://archive.xfce.org/src/xfce/${pkgname}/4.6/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('88de59b222cb9977f93a4c61011c1e1f')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --disable-static # --enable-xinerama
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install || return 1
+}