summaryrefslogtreecommitdiffstats
path: root/abs/extra/libxklavier/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/libxklavier/PKGBUILD')
-rw-r--r--abs/extra/libxklavier/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/extra/libxklavier/PKGBUILD b/abs/extra/libxklavier/PKGBUILD
new file mode 100644
index 0000000..02ca7e3
--- /dev/null
+++ b/abs/extra/libxklavier/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 20594 2008-12-05 21:38:46Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Arjan Timmerman <arjan@archlinux.org>
+
+pkgname=libxklavier
+pkgver=3.8
+pkgrel=1
+pkgdesc="High-level API for X Keyboard Extension"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('libxkbfile>=1.0.5' 'libxml2>=2.6.32' 'glib2>=2.18.3' 'xkeyboard-config>=1.4' 'iso-codes')
+makedepends=('pkgconfig')
+options=('!libtool' '!emptydirs')
+url="http://gswitchit.sourceforge.net"
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('e4f1b9e600c4159f39d38ab94d56cf9b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --with-xkb-base=/usr/share/X11/xkb --disable-static || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+}