summaryrefslogtreecommitdiffstats
path: root/abs/extra/lua/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/lua/PKGBUILD')
-rw-r--r--abs/extra/lua/PKGBUILD65
1 files changed, 38 insertions, 27 deletions
diff --git a/abs/extra/lua/PKGBUILD b/abs/extra/lua/PKGBUILD
index 9ed38d8..5f10af4 100644
--- a/abs/extra/lua/PKGBUILD
+++ b/abs/extra/lua/PKGBUILD
@@ -1,42 +1,53 @@
-# $Id: PKGBUILD 156332 2012-04-17 10:35:09Z bluewind $
-# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# $Id$
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Juergen Hoetzel <juergen@archlinux.org>
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
-pkgname=lua
-pkgver=5.1.5
-pkgrel=2
-pkgdesc="A powerful light-weight programming language designed for extending applications"
+pkgname=lua
+pkgver=5.2.3
+pkgrel=1
+pkgdesc='Powerful light-weight programming language designed for extending applications'
arch=('i686' 'x86_64')
-url="http://www.lua.org/"
+url='http://www.lua.org/'
depends=('readline')
license=('MIT')
options=('!makeflags' '!emptydirs')
-source=(http://www.lua.org/ftp/${pkgname}-${pkgver}.tar.gz
- lua-arch.patch lua-5.1-cflags.diff)
-md5sums=('2e115fe26e435e33b0d5c022e4490567'
- 'fa25feb70ef9fec975b1c20da5098b3c'
- '249582bf1fd861ccf492d2c35a9fe732')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/lua-arch.patch"
- patch -p1 -i "${srcdir}/lua-5.1-cflags.diff"
+source=(http://www.lua.org/ftp/$pkgname-$pkgver.tar.gz
+ liblua.so.patch
+ lua.pc
+ LICENSE)
+md5sums=('dc7f94ec6ff15c985d2d6ad0f1b35654'
+ 'bdc663c7b82ffc0b5df67611621fb625'
+ 'e7ba6c2b695b0b84a5ea0cbff5fc9067'
+ '0e2bd67b909b9ff673da844ca3480df2')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../liblua.so.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+
export CFLAGS="$CFLAGS -fPIC"
+ make MYCFLAGS="$CFLAGS" MYLDFLAGS="$LDFLAGS" linux
- make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1" \
- INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
- linux
+ sed "s/%VER%/${pkgver%.*}/g;s/%REL%/$pkgver/g" ../lua.pc > lua.pc
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make INSTALL_DATA="cp -d" TO_LIB="liblua.a liblua.so liblua.so.5.1 liblua.so.$pkgver" \
- INSTALL_TOP="${pkgdir}/usr" INSTALL_MAN="${pkgdir}/usr/share/man/man1" \
+ cd $pkgname-$pkgver
+
+ make \
+ TO_LIB='liblua.a liblua.so liblua.so.5.2 liblua.so.5.2.3' \
+ INSTALL_DATA='cp -d' \
+ INSTALL_TOP="$pkgdir"/usr \
+ INSTALL_MAN="$pkgdir"/usr/share/man/man1 \
install
- install -D -m644 etc/lua.pc "${pkgdir}/usr/lib/pkgconfig/lua.pc"
- install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
+ install -Dm644 lua.pc "$pkgdir"/usr/lib/pkgconfig/lua.pc
# Install the documentation
- install -d "${pkgdir}/usr/share/doc/lua"
- install -m644 doc/*.{gif,png,css,html} "${pkgdir}/usr/share/doc/lua"
+ install -d "$pkgdir"/usr/share/doc/lua
+ install -m644 doc/*.{gif,png,css,html} "$pkgdir"/usr/share/doc/lua
+ install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}