summaryrefslogtreecommitdiffstats
path: root/abs/extra/mercurial/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/mercurial/PKGBUILD')
-rw-r--r--abs/extra/mercurial/PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/abs/extra/mercurial/PKGBUILD b/abs/extra/mercurial/PKGBUILD
index 0ce6012..7c146f5 100644
--- a/abs/extra/mercurial/PKGBUILD
+++ b/abs/extra/mercurial/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 97863 2010-11-02 05:48:54Z giovanni $
+# $Id: PKGBUILD 99614 2010-11-15 21:11:47Z giovanni $
# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
pkgname=mercurial
-pkgver=1.7
-pkgrel=1
+pkgver=1.7.1
+pkgrel=2
pkgdesc="A scalable distributed SCM tool"
arch=('i686' 'x86_64')
url="http://www.selenic.com/mercurial"
@@ -13,15 +13,15 @@ depends=('python2')
optdepends=('tk: for the hgk GUI')
source=(http://www.selenic.com/mercurial/release/${pkgname}-${pkgver}.tar.gz
mercurial.profile)
-md5sums=('698948ff128d265db55bee8149445556'
+md5sums=('b14caa0f9e4dd5acbf9e9a6059c37fd3'
'43e1d36564d4c7fbe9a091d3ea370a44')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}/" --optimize=1 || return 1
- #sed -i -e 's#env python#env python2#' \
- # "${pkgdir}"/usr/lib/python2.7/site-packages/mercurial/lsprof.py
+ sed -i -e 's#env python#env python2#' \
+ "${pkgdir}"/usr/lib/python2.6/site-packages/mercurial/lsprof.py
install -d ${pkgdir}/usr/share/man/{man1,man5}
install -m644 doc/hg.1 "${pkgdir}/usr/share/man/man1" || return 1