summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythexpress
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/mythexpress')
-rwxr-xr-xabs/extra/mythexpress/PKGBUILD46
-rwxr-xr-xabs/extra/mythexpress/mythexpress.html30
2 files changed, 76 insertions, 0 deletions
diff --git a/abs/extra/mythexpress/PKGBUILD b/abs/extra/mythexpress/PKGBUILD
new file mode 100755
index 0000000..37a9dfb
--- /dev/null
+++ b/abs/extra/mythexpress/PKGBUILD
@@ -0,0 +1,46 @@
+pkgname=mythexpress
+pkgver=20121210
+pkgrel=2
+pkgdesc="MythExpress is a browser-based interface to MythTV HTTP streaming capability"
+arch=('i686' 'x86_64')
+url="https://github.com/MythTV-Clients/MythExpress"
+license=('GPL3')
+depends=('nodejs' 'avahi' )
+makedepends=('git')
+source=('mythexpress.html' )
+
+_gitroot="https://github.com/MythTV-Clients/MythExpress.git"
+_gitname=MythExpress
+
+build() {
+ cd "${srcdir}"
+
+ if [ ! -d "${srcdir}/${_gitname}" ]; then
+ git clone ${_gitroot}
+ else
+ cd ${_gitname} && git pull origin
+ fi
+
+ msg "GIT checkout done."
+
+
+ cd "${srcdir}"
+ if [ -e ${_gitname}-build ]
+ then
+ rm -rf ${_gitname}-build
+ fi
+ cp -rf "${_gitname}" "${_gitname}-build"
+
+ cd "${srcdir}/${_gitname}-build"
+ npm install || exit 1
+
+}
+
+package() {
+ cd "${srcdir}"
+ mkdir -p $pkgdir/usr/$pkgname
+ rsync -arvp --exclude .git ${_gitname}-build/ $pkgdir/usr/${pkgname}
+ cd $startdir/src
+ install -m755 -D mythexpress.html $pkgdir/data/srv/httpd/htdocs/mythexpress.html
+}
+md5sums=('93b0d936c5c7838e1c0367f2d5286b3b')
diff --git a/abs/extra/mythexpress/mythexpress.html b/abs/extra/mythexpress/mythexpress.html
new file mode 100755
index 0000000..d9dd9a3
--- /dev/null
+++ b/abs/extra/mythexpress/mythexpress.html
@@ -0,0 +1,30 @@
+<head>
+<script type="text/javascript">
+function r()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":6544" ) ;
+
+}
+
+function express()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":6565" ) ;
+
+ }
+
+function remyth()
+{
+ current_hostname=parent.location.hostname
+ top.frames["content"].location.href = ( "http://" + current_hostname + ":8088" ) ;
+
+ }
+
+
+</script>
+</head>
+<body onload="JavaScript:express();">
+
+</body>
+</html> \ No newline at end of file