summaryrefslogtreecommitdiffstats
path: root/abs/extra/mythvodka/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/mythvodka/PKGBUILD')
-rw-r--r--abs/extra/mythvodka/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/mythvodka/PKGBUILD b/abs/extra/mythvodka/PKGBUILD
new file mode 100644
index 0000000..0832093
--- /dev/null
+++ b/abs/extra/mythvodka/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 5936 2008-07-21 20:24:16Z thomas $
+# Maintainer: Cecil Watson<knoppmyth@gmail.com>
+
+pkgname=mythvodka
+pkgver=0.7
+pkgrel=11
+pkgdesc="MythVodka (Video On Demand Killer App) is a plugin for MythTV allowing streaming of BBC iPlayer, Hulu, HTTP and NZB content."
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://code.google.com/p/mythvodka/"
+depends=('rtmpdump' 'perl-xml-dom' 'beautiful-soup')
+install=mythvodka.install
+source=('http://mythvodka.googlecode.com/files/mythvodka.07.tar.gz' 'mythvodka.diff' 'hulu_grabber.sh' 'http://ftp.knoppmyth/R6/sources/huludata.tar.bz2')
+
+build() {
+ patch -p0 < mythvodka.diff
+ cd $startdir/src/mythvodka/mythvodka
+ rm -fr Makefile
+ qmake mythvodka.pro
+ make
+ mkdir -p $startdir/pkg/usr/lib/mythtv/plugins/
+ cp libmythvodka.so $startdir/pkg/usr/lib/mythtv/plugins/
+ strip --strip-unneeded $startdir/pkg/usr/lib/mythtv/plugins/libmythvodka.so
+ mkdir -p $startdir/pkg/usr/share/mythtv/themes/default/
+ cp streams-ui.xml $startdir/pkg/usr/share/mythtv/themes/default/
+ mkdir -p $startdir/pkg/usr/share/mythtv/themes/default-wide/
+ cp theme-wide/streams-ui.xml $startdir/pkg/usr/share/mythtv/themes/default-wide/
+ mkdir -p $startdir/pkg/usr/local/bin
+ chmod a+x ../scripts/*
+ cp -p ../scripts/* $startdir/pkg/usr/local/bin
+ mkdir -p $startdir/pkg/etc/cron.daily/
+ chmod 755 ../../hulu_grabber.sh
+ cp ../../hulu_grabber.sh $startdir/pkg/etc/cron.daily/
+ mkdir -p $startdir/pkg/var/tmp
+ cp $startdir/src/huludata.xml $startdir/pkg/var/tmp
+}