summaryrefslogtreecommitdiffstats
path: root/abs/extra/ncdu/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/ncdu/PKGBUILD')
-rw-r--r--abs/extra/ncdu/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/ncdu/PKGBUILD b/abs/extra/ncdu/PKGBUILD
new file mode 100644
index 0000000..011f7e0
--- /dev/null
+++ b/abs/extra/ncdu/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 76727 2012-09-27 22:43:52Z bisson $
+
+# Contributor: lp76 <l.peduto@gmail.com>
+# Contributor: Daenyth <Daenyth+Arch AT gmail DOT com>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=ncdu
+pkgver=1.9
+pkgrel=1
+pkgdesc='Disk usage analyzer with an ncurses interface'
+url='http://dev.yorhel.nl/ncdu/'
+license=('custom:MIT')
+depends=('ncurses')
+arch=('i686' 'x86_64')
+source=("http://dev.yorhel.nl/download/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('27cb5464b192db8ffdf0a894fe51d29985348eb0')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}