summaryrefslogtreecommitdiffstats
path: root/abs/extra/numlockx/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/numlockx/PKGBUILD')
-rw-r--r--abs/extra/numlockx/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/numlockx/PKGBUILD b/abs/extra/numlockx/PKGBUILD
new file mode 100644
index 0000000..172cceb
--- /dev/null
+++ b/abs/extra/numlockx/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 19225 2008-11-17 22:12:15Z thayer $
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Travis Willard <travisw@wmpub.ca>
+# Maintainer: Thayer Williams <thayer@archlinux.org>
+
+pkgname=numlockx
+pkgver=1.1
+pkgrel=4
+pkgdesc="Turns on the numlock key in X11"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="http://ktown.kde.org/~seli/numlockx/"
+depends=('libxtst')
+source=(http://ktown.kde.org/~seli/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('127d9dfbbbe6dbec62cc78db340f913c')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr x_includes=/usr/include/X11 \
+ x_libraries=/usr/lib || return 1
+ make || return 1
+ make prefix=$pkgdir/usr install || return 1
+
+ # Install the custom MIT license
+ install -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE || return 1
+}