summaryrefslogtreecommitdiffstats
path: root/abs/extra/ocaml-findlib
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/ocaml-findlib')
-rw-r--r--abs/extra/ocaml-findlib/PKGBUILD19
-rw-r--r--abs/extra/ocaml-findlib/externalmeta6.patch13
-rw-r--r--abs/extra/ocaml-findlib/makefile.patch13
3 files changed, 20 insertions, 25 deletions
diff --git a/abs/extra/ocaml-findlib/PKGBUILD b/abs/extra/ocaml-findlib/PKGBUILD
index efe122f..110dff0 100644
--- a/abs/extra/ocaml-findlib/PKGBUILD
+++ b/abs/extra/ocaml-findlib/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Thomas S Hatch <thatch45@gmail.com>
@@ -8,16 +7,15 @@
# Contributor: Alif <alive4ever@live.com>
pkgname=ocaml-findlib
-pkgver=1.7.1
-pkgrel=1
+pkgver=1.8.0
+pkgrel=3
pkgdesc='OCaml package manager'
-arch=('x86_64' 'i686')
+arch=('x86_64')
url='http://projects.camlcity.org/projects/findlib.html'
license=('MIT')
-depends=('ocaml')
-makedepends=('setconf')
+depends=('ocaml-compiler-libs')
source=("http://download.camlcity.org/download/findlib-$pkgver.tar.gz")
-sha256sums=('5d4b9a79e9abf8be0b509f6b8cf5696221cbe14fa2fbb2bb352342755fd15eef')
+sha256sums=('2b7b7d6d65bb0f3f8a2c51c63c02b0bcf1fea4c23513f866140dc7dc24fe27ad')
options=('staticlibs' '!strip' 'zipman' '!makeflags')
build() {
@@ -36,11 +34,8 @@ package () {
make prefix="$pkgdir" install
- # Add a directory to the path for compatibility with old-style packages
- #setconf "$pkgdir/etc/findlib.conf" path='"/usr/lib/ocaml:/usr/lib/ocaml-site-lib"'
-
- install -m755 src/findlib/ocamlfind_opt "$pkgdir/usr/bin/"
+ install -Dm755 src/findlib/ocamlfind_opt "$pkgdir/usr/bin/ocamlfind_opt"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et:
diff --git a/abs/extra/ocaml-findlib/externalmeta6.patch b/abs/extra/ocaml-findlib/externalmeta6.patch
new file mode 100644
index 0000000..7dbe9aa
--- /dev/null
+++ b/abs/extra/ocaml-findlib/externalmeta6.patch
@@ -0,0 +1,13 @@
+Index: findlib-1.7.2/configure
+===================================================================
+--- findlib-1.7.2.orig/configure
++++ findlib-1.7.2/configure
+@@ -557,7 +557,7 @@ fi
+
+ # Generate the META files now.
+
+-l="$ldbm dynlink graphics $lnum str threads unix stdlib bigarray ocamldoc $llabltk $lcamlp4 $lobuild $lcomplibs $lbytes $lspacetime"
++l="$ldbm dynlink graphics $lnum str threads unix stdlib bigarray ocamldoc $lcomplibs $lbytes $lspacetime"
+
+ for dir in site-lib-src/*; do
+ # We do not really know if $dir is a directory.
diff --git a/abs/extra/ocaml-findlib/makefile.patch b/abs/extra/ocaml-findlib/makefile.patch
deleted file mode 100644
index 0e21a2d..0000000
--- a/abs/extra/ocaml-findlib/makefile.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -71,7 +71,7 @@ findlib.conf: findlib.conf.in
-
- .PHONY: install-doc
- install-doc:
-- mkdir -p "$(prefix)$(OCAMLFIND_MAN)/man1" "$(prefix)$(OCAMLFIND_MAN)/man3 $(prefix)$(OCAMLFIND_MAN)/man5"
-+ mkdir -p "$(prefix)$(OCAMLFIND_MAN)/man1" "$(prefix)$(OCAMLFIND_MAN)/man3" "$(prefix)$(OCAMLFIND_MAN)/man5"
- -cp doc/ref-man/ocamlfind.1 "$(prefix)$(OCAMLFIND_MAN)/man1"
- -cp doc/ref-man/META.5 doc/ref-man/site-lib.5 doc/ref-man/findlib.conf.5 "$(prefix)$(OCAMLFIND_MAN)/man5"
-