summaryrefslogtreecommitdiffstats
path: root/abs/extra/ocaml/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/ocaml/PKGBUILD')
-rw-r--r--abs/extra/ocaml/PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/abs/extra/ocaml/PKGBUILD b/abs/extra/ocaml/PKGBUILD
index 1ca7fe5..7b0cd86 100644
--- a/abs/extra/ocaml/PKGBUILD
+++ b/abs/extra/ocaml/PKGBUILD
@@ -1,24 +1,24 @@
-# $Id: PKGBUILD 28732 2009-03-01 22:25:49Z tpowa $
-#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# $Id: PKGBUILD 88099 2010-08-19 13:05:24Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=ocaml
-pkgver=3.11.0
+pkgver=3.12.0
pkgrel=1
-pkgdesc="Ocaml compiler - Ocaml is a functional language with OO extensions"
-arch=(i686 x86_64)
+pkgdesc="A functional language with OO extensions"
+arch=('i686' 'x86_64')
license=('LGPL2' 'custom: QPL-1.0')
url="http://caml.inria.fr/"
depends=('gdbm')
makedepends=('tk' 'ncurses>=5.6-7' 'libx11')
-optdepends=('ncurses=5.6-7: advanced ncurses features' 'tk: advanced tk features')
-source=(http://caml.inria.fr/distrib/ocaml-3.11/$pkgname-$pkgver.tar.gz)
+optdepends=('ncurses: advanced ncurses features' 'tk: advanced tk features')
+source=(http://caml.inria.fr/distrib/ocaml-3.12/$pkgname-$pkgver.tar.gz)
options=('!makeflags' '!emptydirs')
build() {
cd $srcdir/$pkgname-$pkgver
- ./configure -prefix /usr
+ ./configure -prefix /usr
make world.opt || return 1
- make PREFIX=$pkgdir/usr install || return 1
+ make PREFIX=$pkgdir/usr MANDIR=$pkgdir/usr/share/man install || return 1
# Save >10MB with this one, makepkg only strips debug symbols.
find ${startdir}/pkg/usr/lib -type f -name '*.so.*' -exec strip --strip-unneeded {} \;
@@ -26,4 +26,4 @@ build() {
# install license
install -D -m 644 $startdir/src/$pkgname-$pkgver/LICENSE $startdir/pkg/usr/share/licenses/ocaml/LICENSE
}
-md5sums=('be152066bdf09761ddf1c31291e5cb90')
+md5sums=('3ba7cc65123c3579f14e7c726d3ee782')