summaryrefslogtreecommitdiffstats
path: root/abs/extra/ocaml/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/ocaml/PKGBUILD')
-rw-r--r--abs/extra/ocaml/PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/abs/extra/ocaml/PKGBUILD b/abs/extra/ocaml/PKGBUILD
index e7ad5ec..f1b1343 100644
--- a/abs/extra/ocaml/PKGBUILD
+++ b/abs/extra/ocaml/PKGBUILD
@@ -1,30 +1,31 @@
-# $Id: PKGBUILD 143814 2011-11-29 13:33:35Z stephane $
+# $Id$
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgbase='ocaml'
pkgname=('ocaml' 'ocaml-compiler-libs')
-pkgver=3.12.1
-pkgrel=3
+pkgver=4.02.3
+pkgrel=2
pkgdesc="A functional language with OO extensions"
arch=('i686' 'x86_64')
-license=('LGPL2' 'custom: QPL-1.0')
+license=('LGPL2.1' 'custom: QPL-1.0')
url="http://caml.inria.fr/"
depends=('gdbm')
-makedepends=('tk' 'ncurses>=5.6-7' 'libx11')
+makedepends=('tk>=8.6.0' 'ncurses>=5.6-7' 'libx11')
optdepends=('ncurses: advanced ncurses features' 'tk: advanced tk features')
-source=(http://caml.inria.fr/distrib/ocaml-3.12/${pkgname}-${pkgver}.tar.gz)
-options=('!makeflags' '!emptydirs')
+source=(http://caml.inria.fr/distrib/ocaml-4.02/${pkgname}-${pkgver}.tar.gz)
+md5sums=('ef1a324608c97031cbd92a442d685ab7')
+options=('!makeflags' '!emptydirs' 'staticlibs')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure -prefix /usr
+ ./configure -prefix /usr -x11include /usr/include
make world.opt
}
package_ocaml() {
cd "${srcdir}/${pkgbase}-${pkgver}"
make PREFIX="${pkgdir}/usr" MANDIR="${pkgdir}/usr/share/man" install
-
+
# Save >10MB with this one, makepkg only strips debug symbols.
#find "${pkgdir}/usr/lib" -type f -name '*.so.*' -exec strip --strip-unneeded {} \;
@@ -54,4 +55,3 @@ optdepends=()
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
}
-md5sums=('814a047085f0f901ab7d8e3a4b7a9e65')