summaryrefslogtreecommitdiffstats
path: root/abs/extra/ocamlbuild/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/ocamlbuild/PKGBUILD')
-rw-r--r--abs/extra/ocamlbuild/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/extra/ocamlbuild/PKGBUILD b/abs/extra/ocamlbuild/PKGBUILD
new file mode 100644
index 0000000..25fa398
--- /dev/null
+++ b/abs/extra/ocamlbuild/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: Jürgen Hötzel <juergen@hoetzel.info>
+
+pkgname=ocamlbuild
+pkgver=0.9.3
+pkgrel=1
+pkgdesc='Build tool, that has built-in rules for building OCaml library and programs'
+arch=('x86_64' 'i686')
+license=('GPL2')
+url='https://github.com/ocaml/ocamlbuild/releases'
+depends=('ocaml>=4.04.0')
+options=('!makeflags')
+source=("https://github.com/ocaml/${pkgname}/archive/$pkgver.tar.gz")
+sha1sums=('16d15d90689b3748a2727e02e03c99a8c2d9ccc7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+