summaryrefslogtreecommitdiffstats
path: root/abs/extra/openjpeg/30_fix_build_for_debian.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/openjpeg/30_fix_build_for_debian.dpatch')
-rw-r--r--abs/extra/openjpeg/30_fix_build_for_debian.dpatch70
1 files changed, 70 insertions, 0 deletions
diff --git a/abs/extra/openjpeg/30_fix_build_for_debian.dpatch b/abs/extra/openjpeg/30_fix_build_for_debian.dpatch
new file mode 100644
index 0000000..afd9950
--- /dev/null
+++ b/abs/extra/openjpeg/30_fix_build_for_debian.dpatch
@@ -0,0 +1,70 @@
+
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 30_fix_build_for_debian.dpatch by <robin.cornelius@gmail.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Dont apply the -s strip flag to the shared lib debian will do it for us
+## DP: where necessary
+## DP: Remove unnecessary linkage on lstdc++ and lm and add missing linkage for -lm
+
+@DPATCH@
+
+Index: ./Makefile
+===================================================================
+--- ./Makefile (revision 96)
++++ ./Makefile (working copy)
+@@ -18,8 +18,7 @@
+ # Converts cr/lf to just lf
+ DOS2UNIX = dos2unix
+
+-COMPILERFLAGS = -Wall -O3 -ffast-math -std=c99 -fPIC
+-LIBRARIES = -lstdc++
++COMPILERFLAGS = -Wall -O3 -ffast-math -std=c99 -fPIC -g $(EXTRA_CFLAGS)
+
+ MODULES = $(SRCS:.c=.o)
+ CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
+@@ -54,7 +53,7 @@
+ $(AR) r $@ $(MODULES)
+
+ $(SHAREDLIB): $(MODULES)
+- $(CC) -s -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) $(LIBRARIES)
++ $(CC) -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) -lm
+
+ install: OpenJPEG
+ install -d '$(DESTDIR)$(INSTALL_LIBDIR)' '$(DESTDIR)$(INSTALL_INCLUDE)'
+
+Index: ./indexer_JPIP/Makefile
+===================================================================
+--- ./indexer_JPIP/Makefile (revision 95)
++++ ./indexer_JPIP/Makefile (working copy)
+@@ -1,7 +1,6 @@
+ CC = gcc
+
+-LDFLAGS = -lm
+-CFLAGS = -Wall
++CFLAGS = -Wall $(EXTRA_CFLAGS)
+
+ all: index_create
+
+Index: ./codec/Makefile
+===================================================================
+--- ./codec/Makefile (revision 96)
++++ ./codec/Makefile (working copy)
+@@ -1,13 +1,13 @@
+ # Makefile for the main OpenJPEG codecs: j2k_to_image and image_to_j2k
+
+-CFLAGS = -O3 -lstdc++ # -g -p -pg
++CFLAGS = $(EXTRA_CFLAGS) # -g -p -pg
+
+ all: j2k_to_image image_to_j2k
+
+-j2k_to_image: j2k_to_image.c ../libopenjpeg.a
++j2k_to_image: j2k_to_image.c
+ gcc $(CFLAGS) compat/getopt.c index.c convert.c j2k_to_image.c -o j2k_to_image -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+-image_to_j2k: image_to_j2k.c ../libopenjpeg.a
++image_to_j2k: image_to_j2k.c
+ gcc $(CFLAGS) compat/getopt.c index.c convert.c image_to_j2k.c -o image_to_j2k -L.. -lopenjpeg -I ../libopenjpeg/ -lm -ltiff
+
+ clean:
+