summaryrefslogtreecommitdiffstats
path: root/abs/extra/openpht/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/openpht/PKGBUILD')
-rw-r--r--abs/extra/openpht/PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/abs/extra/openpht/PKGBUILD b/abs/extra/openpht/PKGBUILD
index 6ccd7e9..06afae1 100644
--- a/abs/extra/openpht/PKGBUILD
+++ b/abs/extra/openpht/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
pkgname=openpht
-pkgver=1.6.2.123
-_pkghash=e23a7eef
-pkgrel=5
+pkgver=1.7.1.137
+_pkghash=b604995c
+pkgrel=2
pkgdesc='OpenPHT is a community driven fork of Plex Home Theater'
arch=('i686' 'x86_64')
url='https://github.com/RasPlex/OpenPHT/'
@@ -21,15 +21,15 @@ depends=('alsa-lib' 'avahi' 'boost-libs' 'curl' 'expat' 'ffmpeg2.8' 'freetype2'
'libxext' 'libxrandr' 'lzo' 'pcre' 'python2' 'sdl' 'sdl_image'
'sdl_mixer' 'sqlite' 'smbclient' 'taglib' 'tinyxml' 'yajl' 'zlib' 'rtmpdump')
makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'shairplay'
- 'libcec' 'libplist' 'nasm' 'swig' 'unzip' 'zip')
+ 'libcec' 'libplist' 'nasm' 'swig' 'unzip' 'zip' 'gcc-libs' 'glibc' 'llvm-libs')
optdepends=('libplist: AirPlay support'
'libcec: Pulse-Eight USB-CEC adapter support'
'shairplay: Shairplay Support')
source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.gz"
- 'plexhometheater.sh'
'plex_lib.conf'
'fribidi.patch'
'plexhometheater.desktop')
+
prepare() {
cd OpenPHT-${pkgver}-${_pkghash}
patch -Np1 <../fribidi.patch
@@ -57,11 +57,7 @@ package() {
cd OpenPHT-${pkgver}-${_pkghash}/build
make DESTDIR="${pkgdir}" install
- install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
- mv "${pkgdir}"/usr/bin/{system,xbmc-xrandr} "${pkgdir}"/usr/lib/plexhometheater/
- mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
- rm -rf "${pkgdir}"/usr/bin/*.so
- install -Dm 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/LH/bin/plexhometheater.sh
+ install -dm 755 "${pkgdir}"/usr/{share/{applications,pixmaps}}
install -m 644 "${srcdir}"/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
@@ -69,8 +65,7 @@ package() {
# add in plex_lib.conf
install -D -m0744 ${srcdir}/plex_lib.conf ${pkgdir}/etc/gen_lib_xml.d/plex_lib.conf
}
-md5sums=('075d697793b32d34c9ac57b94ae14821'
- 'ad57396d98692dbe8c8d6f2fab707a94'
- 'c1eedd9f89ee727230833db9ef1e5d29'
+md5sums=('9a7a2205a30f1002b2600cf8e240fb98'
+ 'b9524fe29d0cc65087ba447d1b892da2'
'a5980579c1b6341a6d06e80d9da2a924'
'e530e2b4d8333863ba1c87862c291ba1')