summaryrefslogtreecommitdiffstats
path: root/abs/extra/openpht/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/openpht/PKGBUILD')
-rw-r--r--[-rwxr-xr-x]abs/extra/openpht/PKGBUILD59
1 files changed, 30 insertions, 29 deletions
diff --git a/abs/extra/openpht/PKGBUILD b/abs/extra/openpht/PKGBUILD
index 45c52f7..6ccd7e9 100755..100644
--- a/abs/extra/openpht/PKGBUILD
+++ b/abs/extra/openpht/PKGBUILD
@@ -1,33 +1,38 @@
+# Maintainer: Jeff Keyte <jeff@keyte.me>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
+
pkgname=openpht
-pkgver=1.5.2.514
-_pkghash=310d4f7e
-pkgrel=2
-pkgdesc='OpenPHT a community driven fork of Plex Home Theater'
+pkgver=1.6.2.123
+_pkghash=e23a7eef
+pkgrel=5
+pkgdesc='OpenPHT is a community driven fork of Plex Home Theater'
arch=('i686' 'x86_64')
-url='https://github.com/RasPlex/OpenPHT'
+url='https://github.com/RasPlex/OpenPHT/'
license=('GPL2')
install="${pkgname}.install"
provides=('plex-home-theater')
#conflicts=('plex-home-theater')
replaces=('plex-home-theater')
-depends=('boost-libs' 'curl' 'ffmpeg-compat' 'glew' 'libcdio' 'libmad'
- 'libmicrohttpd' 'libmpeg2' 'libsamplerate' 'libssh' 'libusb-compat'
- 'libvdpau' 'libxrandr' 'lzo' 'sdl_image' 'sdl_mixer' 'smbclient'
- 'taglib' 'tinyxml' 'yajl')
-makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'libcec'
- 'libplist' 'libshairport' 'nasm' 'swig' 'unzip' 'zip')
+depends=('alsa-lib' 'avahi' 'boost-libs' 'curl' 'expat' 'ffmpeg2.8' 'freetype2' 'fribidi'
+ 'gcc-libs' 'glew' 'glibc' 'glu' 'libcdio' 'libgl' 'libjpeg' 'libmad'
+ 'libmicrohttpd' 'libmpeg2' 'libpng' 'libsamplerate' 'llvm-libs'
+ 'libssh' 'libtiff' 'libusb-compat' 'libva' 'libvdpau' 'libx11'
+ 'libxext' 'libxrandr' 'lzo' 'pcre' 'python2' 'sdl' 'sdl_image'
+ 'sdl_mixer' 'sqlite' 'smbclient' 'taglib' 'tinyxml' 'yajl' 'zlib' 'rtmpdump')
+makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'shairplay'
+ 'libcec' 'libplist' 'nasm' 'swig' 'unzip' 'zip')
optdepends=('libplist: AirPlay support'
- 'libshairport: AirPlay support'
- 'libcec: Pulse-Eight USB-CEC adapter support')
+ 'libcec: Pulse-Eight USB-CEC adapter support'
+ 'shairplay: Shairplay Support')
source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.gz"
- 'plex-ffmpeg-compat.patch'
+ 'plexhometheater.sh'
'plex_lib.conf'
- 'plexhometheater.sh')
-
+ 'fribidi.patch'
+ 'plexhometheater.desktop')
prepare() {
cd OpenPHT-${pkgver}-${_pkghash}
-
- patch -Np1 -i ../plex-ffmpeg-compat.patch
+ patch -Np1 <../fribidi.patch
}
build() {
@@ -38,12 +43,9 @@ build() {
fi
mkdir build && cd build
+ CMAKE_PREFIX_PATH=/usr/lib/ffmpeg2.8:/usr/include/ffmpeg2.8 \
cmake .. \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_C_FLAGS="$CMAKE_C_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
- -DCMAKE_CXX_FLAGS="$CMAKE_CXX_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
- -DCREATE_BUNDLE='FALSE' \
- -DDUMP_SYMBOLS='FALSE' \
-DENABLE_AUTOUPDATE='FALSE' \
-DENABLE_PYTHON='TRUE' \
-DPYTHON_EXEC='/usr/bin/python2' \
@@ -60,16 +62,15 @@ package() {
mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
rm -rf "${pkgdir}"/usr/bin/*.so
install -Dm 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/LH/bin/plexhometheater.sh
- install -m 644 ../plex/Resources/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
+ install -m 644 "${srcdir}"/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
# LinHES stuff
- #add in plex_lib.conf
+ # add in plex_lib.conf
install -D -m0744 ${srcdir}/plex_lib.conf ${pkgdir}/etc/gen_lib_xml.d/plex_lib.conf
}
-
-# vim: ts=2 sw=2 et:
-md5sums=('4cefcfc40b4c5bb890cd74e62ca0e1ac'
- '6704244166497db7fa6b3ddd43a0e53b'
+md5sums=('075d697793b32d34c9ac57b94ae14821'
+ 'ad57396d98692dbe8c8d6f2fab707a94'
'c1eedd9f89ee727230833db9ef1e5d29'
- '4ceae60ed2f9e4304eda4f80d407e799')
+ 'a5980579c1b6341a6d06e80d9da2a924'
+ 'e530e2b4d8333863ba1c87862c291ba1')