summaryrefslogtreecommitdiffstats
path: root/abs/extra/openpht/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/openpht/PKGBUILD')
-rwxr-xr-xabs/extra/openpht/PKGBUILD78
1 files changed, 78 insertions, 0 deletions
diff --git a/abs/extra/openpht/PKGBUILD b/abs/extra/openpht/PKGBUILD
new file mode 100755
index 0000000..d3e557e
--- /dev/null
+++ b/abs/extra/openpht/PKGBUILD
@@ -0,0 +1,78 @@
+pkgname=openpht
+pkgver=1.5.0.502
+_pkghash=7563ca94
+pkgrel=1
+pkgdesc='OpenPHT a community driven fork of Plex Home Theater'
+arch=('i686' 'x86_64')
+url='https://github.com/RasPlex/OpenPHT'
+license=('GPL2')
+install="${pkgname}.install"
+provides=('plex-home-theater')
+#conflicts=('plex-home-theater')
+replaces=('plex-home-theater')
+depends=('boost-libs' 'curl' 'ffmpeg-compat' 'glew' 'libcdio' 'libmad'
+ 'libmicrohttpd' 'libmpeg2' 'libsamplerate' 'libssh' 'libusb-compat'
+ 'libvdpau' 'libxrandr' 'lzo' 'sdl_image' 'sdl_mixer' 'smbclient'
+ 'taglib' 'tinyxml' 'yajl')
+makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'libcec'
+ 'libplist' 'libshairport' 'nasm' 'swig' 'unzip' 'zip')
+optdepends=('libplist: AirPlay support'
+ 'libshairport: AirPlay support'
+ 'libcec: Pulse-Eight USB-CEC adapter support')
+source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.gz"
+ 'plex-ffmpeg-compat.patch'
+ 'plex-libcec.patch'
+ 'plex_lib.conf'
+ 'plexhometheater.sh')
+
+prepare() {
+ cd OpenPHT-${pkgver}-${_pkghash}
+
+ patch -Np1 -i ../plex-libcec.patch
+ patch -Np1 -i ../plex-ffmpeg-compat.patch
+}
+
+build() {
+ cd OpenPHT-${pkgver}-${_pkghash}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_C_FLAGS="$CMAKE_C_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
+ -DCMAKE_CXX_FLAGS="$CMAKE_CXX_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
+ -DCREATE_BUNDLE='FALSE' \
+ -DDUMP_SYMBOLS='FALSE' \
+ -DENABLE_AUTOUPDATE='FALSE' \
+ -DENABLE_PYTHON='TRUE' \
+ -DPYTHON_EXEC='/usr/bin/python2' \
+ -DUSE_INTERNAL_FFMPEG='FALSE'
+ make
+}
+
+package() {
+ cd OpenPHT-${pkgver}-${_pkghash}/build
+
+ make DESTDIR="${pkgdir}" install
+ install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
+ mv "${pkgdir}"/usr/bin/{system,xbmc-xrandr} "${pkgdir}"/usr/lib/plexhometheater/
+ mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
+ rm -rf "${pkgdir}"/usr/bin/*.so
+ install -Dm 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/LH/bin/plexhometheater.sh
+ install -m 644 ../plex/Resources/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
+ install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
+
+ # LinHES stuff
+ #add in plex_lib.conf
+ install -D -m0744 ${srcdir}/plex_lib.conf ${pkgdir}/etc/gen_lib_xml.d/plex_lib.conf
+}
+
+# vim: ts=2 sw=2 et:
+md5sums=('48ab91fe4ce6c6e6c6a3177e12d733dc'
+ '6704244166497db7fa6b3ddd43a0e53b'
+ '0f753e1ebea13e5a2029a59b9db79877'
+ 'c1eedd9f89ee727230833db9ef1e5d29'
+ '4ceae60ed2f9e4304eda4f80d407e799')