summaryrefslogtreecommitdiffstats
path: root/abs/extra/openpht
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/openpht')
-rwxr-xr-xabs/extra/openpht/PKGBUILD75
-rw-r--r--abs/extra/openpht/__changelog5
-rw-r--r--abs/extra/openpht/openpht.install11
-rwxr-xr-xabs/extra/openpht/plex-ffmpeg-compat.patch29
-rw-r--r--abs/extra/openpht/plex_lib.conf9
-rwxr-xr-xabs/extra/openpht/plexhometheater.sh11
6 files changed, 140 insertions, 0 deletions
diff --git a/abs/extra/openpht/PKGBUILD b/abs/extra/openpht/PKGBUILD
new file mode 100755
index 0000000..45c52f7
--- /dev/null
+++ b/abs/extra/openpht/PKGBUILD
@@ -0,0 +1,75 @@
+pkgname=openpht
+pkgver=1.5.2.514
+_pkghash=310d4f7e
+pkgrel=2
+pkgdesc='OpenPHT a community driven fork of Plex Home Theater'
+arch=('i686' 'x86_64')
+url='https://github.com/RasPlex/OpenPHT'
+license=('GPL2')
+install="${pkgname}.install"
+provides=('plex-home-theater')
+#conflicts=('plex-home-theater')
+replaces=('plex-home-theater')
+depends=('boost-libs' 'curl' 'ffmpeg-compat' 'glew' 'libcdio' 'libmad'
+ 'libmicrohttpd' 'libmpeg2' 'libsamplerate' 'libssh' 'libusb-compat'
+ 'libvdpau' 'libxrandr' 'lzo' 'sdl_image' 'sdl_mixer' 'smbclient'
+ 'taglib' 'tinyxml' 'yajl')
+makedepends=('boost' 'cmake' 'doxygen' 'git' 'java-environment' 'libcec'
+ 'libplist' 'libshairport' 'nasm' 'swig' 'unzip' 'zip')
+optdepends=('libplist: AirPlay support'
+ 'libshairport: AirPlay support'
+ 'libcec: Pulse-Eight USB-CEC adapter support')
+source=("https://github.com/RasPlex/OpenPHT/archive/v${pkgver}-${_pkghash}.tar.gz"
+ 'plex-ffmpeg-compat.patch'
+ 'plex_lib.conf'
+ 'plexhometheater.sh')
+
+prepare() {
+ cd OpenPHT-${pkgver}-${_pkghash}
+
+ patch -Np1 -i ../plex-ffmpeg-compat.patch
+}
+
+build() {
+ cd OpenPHT-${pkgver}-${_pkghash}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_C_FLAGS="$CMAKE_C_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
+ -DCMAKE_CXX_FLAGS="$CMAKE_CXX_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
+ -DCREATE_BUNDLE='FALSE' \
+ -DDUMP_SYMBOLS='FALSE' \
+ -DENABLE_AUTOUPDATE='FALSE' \
+ -DENABLE_PYTHON='TRUE' \
+ -DPYTHON_EXEC='/usr/bin/python2' \
+ -DUSE_INTERNAL_FFMPEG='FALSE'
+ make
+}
+
+package() {
+ cd OpenPHT-${pkgver}-${_pkghash}/build
+
+ make DESTDIR="${pkgdir}" install
+ install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
+ mv "${pkgdir}"/usr/bin/{system,xbmc-xrandr} "${pkgdir}"/usr/lib/plexhometheater/
+ mv "${pkgdir}"/usr/share/XBMC "${pkgdir}"/usr/share/plexhometheater
+ rm -rf "${pkgdir}"/usr/bin/*.so
+ install -Dm 755 "${srcdir}"/plexhometheater.sh "${pkgdir}"/usr/LH/bin/plexhometheater.sh
+ install -m 644 ../plex/Resources/plexhometheater.desktop "${pkgdir}"/usr/share/applications/
+ install -m 644 ../plex/Resources/plex-icon-256.png "${pkgdir}"/usr/share/pixmaps/plexhometheater.png
+
+ # LinHES stuff
+ #add in plex_lib.conf
+ install -D -m0744 ${srcdir}/plex_lib.conf ${pkgdir}/etc/gen_lib_xml.d/plex_lib.conf
+}
+
+# vim: ts=2 sw=2 et:
+md5sums=('4cefcfc40b4c5bb890cd74e62ca0e1ac'
+ '6704244166497db7fa6b3ddd43a0e53b'
+ 'c1eedd9f89ee727230833db9ef1e5d29'
+ '4ceae60ed2f9e4304eda4f80d407e799')
diff --git a/abs/extra/openpht/__changelog b/abs/extra/openpht/__changelog
new file mode 100644
index 0000000..42c86d8
--- /dev/null
+++ b/abs/extra/openpht/__changelog
@@ -0,0 +1,5 @@
+copied plex-home-theater to openpht
+PKGBUILD - Remove opt dep pulseaudio
+PKGBUILD - Added plex_lib.conf, this file goes in /etc/gen_lib_xml.d/
+PKGBUILD - Install plexhometheater.sh to /usr/LH/bin
+openpht.install - add gen_lib_xml.py to post_install and post_remove and post_update
diff --git a/abs/extra/openpht/openpht.install b/abs/extra/openpht/openpht.install
new file mode 100644
index 0000000..6788abc
--- /dev/null
+++ b/abs/extra/openpht/openpht.install
@@ -0,0 +1,11 @@
+post_install() {
+ gen_lib_xml.py
+}
+
+post_upgrade() {
+ gen_lib_xml.py
+}
+
+post_remove() {
+ gen_lib_xml.py
+}
diff --git a/abs/extra/openpht/plex-ffmpeg-compat.patch b/abs/extra/openpht/plex-ffmpeg-compat.patch
new file mode 100755
index 0000000..1601500
--- /dev/null
+++ b/abs/extra/openpht/plex-ffmpeg-compat.patch
@@ -0,0 +1,29 @@
+diff -rupN plex-home-theater.orig/plex/CMakeModules/FindFFmpeg.cmake plex-home-theater/plex/CMakeModules/FindFFmpeg.cmake
+--- plex-home-theater.orig/plex/CMakeModules/FindFFmpeg.cmake 2014-09-15 11:46:21.751638700 +0200
++++ plex-home-theater/plex/CMakeModules/FindFFmpeg.cmake 2014-09-15 11:43:25.678039000 +0200
+@@ -41,7 +41,7 @@ MACRO(FFMPEG_FIND varname shortname head
+ /opt/csw/include # Blastwave
+ /opt/include
+ /usr/freeware/include
+- PATH_SUFFIXES ffmpeg
++ PATH_SUFFIXES ffmpeg-compat
+ DOC "Location of FFMPEG Headers"
+ )
+
+@@ -62,7 +62,7 @@ MACRO(FFMPEG_FIND varname shortname head
+ /opt/csw/include # Blastwave
+ /opt/include
+ /usr/freeware/include
+- PATH_SUFFIXES ffmpeg
++ PATH_SUFFIXES ffmpeg-compat
+ DOC "Location of FFMPEG Headers"
+ )
+ ENDIF(NOT FFMPEG_${varname}_INCLUDE_DIRS)
+@@ -85,6 +85,7 @@ MACRO(FFMPEG_FIND varname shortname head
+ /opt/csw/lib
+ /opt/lib
+ /usr/freeware/lib64
++ PATH_SUFFIXES ffmpeg-compat
+ DOC "Location of FFMPEG Libraries"
+ )
+
diff --git a/abs/extra/openpht/plex_lib.conf b/abs/extra/openpht/plex_lib.conf
new file mode 100644
index 0000000..1aa78f3
--- /dev/null
+++ b/abs/extra/openpht/plex_lib.conf
@@ -0,0 +1,9 @@
+<!--#PLEX-->
+ <button>
+ <type>MENU_PLEX</type>
+ <text>Launch Plex</text>
+ <description>Open Plex Home Theater</description>
+ <action>EXEC /usr/LH/bin/plexhometheater.sh</action>
+ </button>
+<!--#PLEX-->
+
diff --git a/abs/extra/openpht/plexhometheater.sh b/abs/extra/openpht/plexhometheater.sh
new file mode 100755
index 0000000..579bed6
--- /dev/null
+++ b/abs/extra/openpht/plexhometheater.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+#Stop XScreensaver
+stop_xss.sh &
+
+#Launch plex
+export XBMC_BIN_HOME='/usr/lib/plexhometheater'
+export XBMC_HOME='/usr/share/plexhometheater'
+plexhometheater
+
+#Start Xscreensaver again
+killall stop_xss.sh