summaryrefslogtreecommitdiffstats
path: root/abs/extra/perl-yaml/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/perl-yaml/PKGBUILD')
-rw-r--r--abs/extra/perl-yaml/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/perl-yaml/PKGBUILD b/abs/extra/perl-yaml/PKGBUILD
new file mode 100644
index 0000000..b2e093c
--- /dev/null
+++ b/abs/extra/perl-yaml/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Charles Mauch <cmauch@gmail.com>
+
+pkgname=perl-yaml
+_realname=YAML
+pkgver=0.66
+pkgrel=1
+pkgdesc="Perl/CPAN Module YAML : YAML Aint Markup Language tm"
+arch=(i686 x86_64)
+url="http://search.cpan.org/dist/${_realname}/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=(http://www.cpan.org/authors/id/I/IN/INGY/${_realname}-${pkgver}.tar.gz)
+md5sums=('33a0367cb343e1f0dce20f144d0167ba')
+
+build() {
+ cd ${startdir}/src/${_realname}-${pkgver}
+ # install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=${startdir}/pkg || return 1
+
+ # remove perllocal.pod and .packlist
+ find ${startdir}/pkg -name perllocal.pod -delete
+ find ${startdir}/pkg -name .packlist -delete
+}