summaryrefslogtreecommitdiffstats
path: root/abs/extra/plex-home-theater/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/plex-home-theater/PKGBUILD')
-rwxr-xr-xabs/extra/plex-home-theater/PKGBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/abs/extra/plex-home-theater/PKGBUILD b/abs/extra/plex-home-theater/PKGBUILD
index 42c7df2..122105a 100755
--- a/abs/extra/plex-home-theater/PKGBUILD
+++ b/abs/extra/plex-home-theater/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: Daniel Wallace <daniel.wallace@gatech.edu>
pkgname=plex-home-theater
-pkgver=1.2.2
-pkgrel=6
+_pkgver=1.2.3.378-0c92ed32
+pkgver=${_pkgver%-*}
+pkgrel=1
pkgdesc='Plex Home Theater'
arch=('i686' 'x86_64')
url='http://www.plexapp.com/'
@@ -17,18 +18,16 @@ makedepends=('boost' 'cmake' 'doxygen' 'java-environment' 'libcec' 'libplist'
'libshairport' 'nasm' 'swig' 'unzip' 'zip')
optdepends=('libplist: AirPlay support'
'libshairport: AirPlay support'
- 'libcec: Pulse-Eight USB-CEC adapter support'
- 'pulseaudio: PulseAudio support')
-install="${pkgname}.install"
-source=("https://github.com/plexinc/plex-home-theater-public/archive/pht-v${pkgver}.tar.gz"
+ 'libcec: Pulse-Eight USB-CEC adapter support')
+source=("https://github.com/plexinc/plex-home-theater-public/archive/v${_pkgver}.tar.gz"
'plex-ffmpeg-compat.patch'
'plex-libcec-2.2.0.patch'
'plex-lirc-socket.patch'
- 'plexhometheater.sh'
- 'plex_lib.conf')
+ 'plex_lib.conf'
+ 'plexhometheater.sh')
prepare() {
- cd plex-home-theater-public-pht-v${pkgver}
+ cd plex-home-theater-public-${_pkgver}
patch -Np1 -i ../plex-libcec-2.2.0.patch
patch -Np1 -i ../plex-lirc-socket.patch
@@ -36,7 +35,7 @@ prepare() {
}
build() {
- cd plex-home-theater-public-pht-v${pkgver}
+ cd plex-home-theater-public-${_pkgver}
if [[ -d build ]]; then
rm -rf build
@@ -53,7 +52,7 @@ build() {
}
package() {
- cd plex-home-theater-public-pht-v${pkgver}/build
+ cd plex-home-theater-public-${_pkgver}/build
make DESTDIR="${pkgdir}" install
install -dm 755 "${pkgdir}"/usr/{lib/plexhometheater,share/{applications,pixmaps}}
@@ -69,9 +68,9 @@ package() {
}
# vim: ts=2 sw=2 et:
-md5sums=('10bc6dd7be91a33eba9b666c96f50a20'
+md5sums=('59f6d8386d9533b7c9a0c9e559a83c0f'
'6704244166497db7fa6b3ddd43a0e53b'
'066484ad4949f96ddddaa8b1d4d709e1'
'b96a1d70174d80d3f2272bdc5b48e4a3'
- '8fae1350cc36f40ed65fbf96128a02d0'
- '8735a4e7857bc85085482c4f8bcb1d01')
+ '8735a4e7857bc85085482c4f8bcb1d01'
+ '8fae1350cc36f40ed65fbf96128a02d0')