summaryrefslogtreecommitdiffstats
path: root/abs/extra/plex-home-theater/plex-lirc-socket.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/plex-home-theater/plex-lirc-socket.patch')
-rw-r--r--abs/extra/plex-home-theater/plex-lirc-socket.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/abs/extra/plex-home-theater/plex-lirc-socket.patch b/abs/extra/plex-home-theater/plex-lirc-socket.patch
new file mode 100644
index 0000000..7110252
--- /dev/null
+++ b/abs/extra/plex-home-theater/plex-lirc-socket.patch
@@ -0,0 +1,56 @@
+From c20e1deb62521acaca945fe6af780cdfb477610b Mon Sep 17 00:00:00 2001
+From: Maxime Gauduin <alucryd@gmail.com>
+Date: Thu, 30 Oct 2014 09:43:48 +0100
+Subject: [PATCH] Fix lirc socket path
+
+---
+ configure.in | 4 ++--
+ plex/CMakeModules/PlatformConfigLINUX.cmake | 2 +-
+ plex/CMakeModules/PlatformConfigRPI.cmake | 2 +-
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 002245a..85ad398 100644
+--- a/configure.in
++++ b/configure.in
+@@ -452,9 +452,9 @@ AC_ARG_ENABLE([texturepacker],
+
+ AC_ARG_WITH([lirc-device],
+ [AS_HELP_STRING([--with-lirc-device=file],
+- [specify the default LIRC device (default is /dev/lircd)])],
++ [specify the default LIRC device (default is /var/run/lirc/lircd)])],
+ [lirc_device=$withval],
+- [lirc_device=/dev/lircd])
++ [lirc_device=/var/run/lirc/lircd])
+ AC_DEFINE_UNQUOTED([LIRC_DEVICE], ["$lirc_device"], [Default LIRC device])
+
+ AC_ARG_ENABLE([udev],
+diff --git a/plex/CMakeModules/PlatformConfigLINUX.cmake b/plex/CMakeModules/PlatformConfigLINUX.cmake
+index 078fafb..3afa5c1 100644
+--- a/plex/CMakeModules/PlatformConfigLINUX.cmake
++++ b/plex/CMakeModules/PlatformConfigLINUX.cmake
+@@ -126,7 +126,7 @@ if(DEFINED OPENGL_FOUND)
+ endif()
+
+ #### default lircdevice
+-set(LIRC_DEVICE "/dev/lircd")
++set(LIRC_DEVICE "/var/run/lirc/lircd")
+
+ #### on linux we want to use a "easy" name
+ set(EXECUTABLE_NAME "plexhometheater")
+diff --git a/plex/CMakeModules/PlatformConfigRPI.cmake b/plex/CMakeModules/PlatformConfigRPI.cmake
+index 82aa751..367cdc9 100644
+--- a/plex/CMakeModules/PlatformConfigRPI.cmake
++++ b/plex/CMakeModules/PlatformConfigRPI.cmake
+@@ -103,7 +103,7 @@ list(APPEND CONFIG_INTERNAL_LIBS lib_dllsymbols)
+
+
+ #### default lircdevice
+-set(LIRC_DEVICE "/dev/lircd")
++set(LIRC_DEVICE "/var/run/lirc/lircd")
+
+ #### on linux we want to use a "easy" name
+ set(EXECUTABLE_NAME "plexhometheater")
+--
+2.1.3
+