summaryrefslogtreecommitdiffstats
path: root/abs/extra/polkit/polkit-git-fixes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/extra/polkit/polkit-git-fixes.patch')
-rw-r--r--abs/extra/polkit/polkit-git-fixes.patch85
1 files changed, 85 insertions, 0 deletions
diff --git a/abs/extra/polkit/polkit-git-fixes.patch b/abs/extra/polkit/polkit-git-fixes.patch
new file mode 100644
index 0000000..a0d35e8
--- /dev/null
+++ b/abs/extra/polkit/polkit-git-fixes.patch
@@ -0,0 +1,85 @@
+diff --git a/src/polkit/polkitcheckauthorizationflags.h b/src/polkit/polkitcheckauthorizationflags.h
+index 94aa070..4baa0d1 100644
+--- a/src/polkit/polkitcheckauthorizationflags.h
++++ b/src/polkit/polkitcheckauthorizationflags.h
+@@ -30,10 +30,6 @@
+
+ G_BEGIN_DECLS
+
+-GType polkit_check_authorization_flags_get_type (void) G_GNUC_CONST;
+-
+-#define POLKIT_TYPE_CHECK_AUTHORIZATION_FLAGS (polkit_check_authorization_flags_get_type ())
+-
+ /**
+ * PolkitCheckAuthorizationFlags:
+ * @POLKIT_CHECK_AUTHORIZATION_FLAGS_NONE: No flags set.
+diff --git a/src/polkit/polkiterror.h b/src/polkit/polkiterror.h
+index b31583d..e49cabf 100644
+--- a/src/polkit/polkiterror.h
++++ b/src/polkit/polkiterror.h
+@@ -40,10 +40,6 @@ G_BEGIN_DECLS
+
+ GQuark polkit_error_quark (void);
+
+-GType polkit_error_get_type (void) G_GNUC_CONST;
+-
+-#define POLKIT_TYPE_ERROR (polkit_error_get_type ())
+-
+ /**
+ * PolkitError:
+ * @POLKIT_ERROR_FAILED: The operation failed.
+diff --git a/src/polkit/polkitimplicitauthorization.h b/src/polkit/polkitimplicitauthorization.h
+index 9e5c51c..dee2611 100644
+--- a/src/polkit/polkitimplicitauthorization.h
++++ b/src/polkit/polkitimplicitauthorization.h
+@@ -30,10 +30,6 @@
+
+ G_BEGIN_DECLS
+
+-GType polkit_implicit_authorization_get_type (void) G_GNUC_CONST;
+-
+-#define POLKIT_TYPE_IMPLICIT_AUTHORIZATION (polkit_implicit_authorization_get_type ())
+-
+ /**
+ * PolkitImplicitAuthorization:
+ * @POLKIT_IMPLICIT_AUTHORIZATION_UNKNOWN: Unknown whether the subject is authorized, never returned in any public API.
+diff --git a/src/polkitagent/Makefile.am b/src/polkitagent/Makefile.am
+index d2fc9c8..96ffd7c 100644
+--- a/src/polkitagent/Makefile.am
++++ b/src/polkitagent/Makefile.am
+@@ -46,6 +46,7 @@ libpolkit_agent_1includedir=$(includedir)/polkit-1/polkitagent
+
+ libpolkit_agent_1include_HEADERS = \
+ polkitagent.h \
++ polkitagentenumtypes.h \
+ polkitagenttypes.h \
+ polkitagentsession.h \
+ polkitagentlistener.h \
+diff --git a/src/polkitagent/polkitagenthelperprivate.c b/src/polkitagent/polkitagenthelperprivate.c
+index d4495dd..8f0c878 100644
+--- a/src/polkitagent/polkitagenthelperprivate.c
++++ b/src/polkitagent/polkitagenthelperprivate.c
+@@ -48,8 +48,8 @@ _polkit_clearenv (void)
+ gboolean
+ send_dbus_message (const char *cookie, const char *user)
+ {
+- PolkitAuthority *authority;
+- PolkitIdentity *identity;
++ PolkitAuthority *authority = NULL;
++ PolkitIdentity *identity = NULL;
+ GError *error;
+ gboolean ret;
+
+diff --git a/src/polkitbackend/polkitbackendsessionmonitor.c b/src/polkitbackend/polkitbackendsessionmonitor.c
+index e91ad84..495f752 100644
+--- a/src/polkitbackend/polkitbackendsessionmonitor.c
++++ b/src/polkitbackend/polkitbackendsessionmonitor.c
+@@ -116,7 +116,7 @@ static gboolean
+ ensure_database (PolkitBackendSessionMonitor *monitor,
+ GError **error)
+ {
+- gboolean ret;
++ gboolean ret = FALSE;
+
+ if (monitor->database != NULL)
+ {